Bug 27032 - BUG: spinlock recursion (sys_chdir, user_path_at, do_path_lookup ...)
BUG: spinlock recursion (sys_chdir, user_path_at, do_path_lookup ...)
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: ARM
All Linux
: P1 normal
Assigned To: linux-arm-kernel@lists.arm.linux.org.uk
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2011-01-18 16:58 UTC by Maciej Rutecki
Modified: 2011-01-29 14:32 UTC (History)
3 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-01-18 16:58:05 UTC
Subject    : BUG: spinlock recursion (sys_chdir, user_path_at, do_path_lookup ...)
Submitter  : "Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>
Date       : 2011-01-11 11:05
Message-ID : 20110111110539.GP24920@pengutronix.de
References : http://marc.info/?l=linux-kernel&m=129474395831549&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2011-01-29 14:31:32 UTC
References: http://marc.info/?l=linux-kernel&m=129538921503882&w=2

On Wed, Jan 19, 2011 at 09:19:59AM +1100, Nick Piggin wrote:
> 2011/1/19 Maciej Rutecki <maciej.rutecki@gmail.com>:
> > I created a Bugzilla entry at
> > https://bugzilla.kernel.org/show_bug.cgi?id=27032
> > for your bug report, please add your address to the CC list in there, thanks!
> 
> Sorry I missed this mail. This bug should have been fixed several
> days ago 90dbb77ba48dddb87445d238e84cd137cf97dd98

commit 90dbb77ba48dddb87445d238e84cd137cf97dd98
Author: Nick Piggin <npiggin@kernel.dk>
Date:   Fri Jan 14 02:36:19 2011 +0000

    fs: fix dropping of rcu-walk from force_reval_path

Note You need to log in before you can comment on or make changes to this bug.