Bug 26962 - HVR-1300 tuning problems (MythTV, Kaffeine)
HVR-1300 tuning problems (MythTV, Kaffeine)
Status: CLOSED CODE_FIX
Product: v4l-dvb
Classification: Unclassified
Component: cx88
All Linux
: P1 normal
Assigned To: v4l-dvb_cx88
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-17 17:55 UTC by Jan "Yenya" Kasprzak
Modified: 2012-09-30 09:15 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.35.9-64.fc14.x86_64
Tree: Fedora
Regression: No


Attachments

Description Jan "Yenya" Kasprzak 2011-01-17 17:55:08 UTC
I have a Hauppauge HVR-1300 card, and it does not work in MyhtTV at all (cannot find any channel), and in Kaffeine it displays a single channel, but when trying to switch to a different channel, Kaffeine locks up. After restarting Kaffeine, it displays the newly selected channel, and works until somebody tries to switch to a different channel again.

Tuning using tzap works (it takes about two seconds to obtain a lock):
$ tzap CT\ 1
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
tuning to 538000000 Hz
video pid 0x0101, audio pid 0x0111
status 01 | signal 6767 | snr 8000 | ber 00003fff | unc 00000000 | 
status 1f | signal 6767 | snr ffff | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal 6767 | snr ffff | ber 00000000 | unc 00000000 | FE_HAS_LOCK

When tuned using tzap, the DVB-T stream can be displayed e.g. using mplayer or saved using cat.

I have reported this to the MythTV trac, but the authors claimed this to be a driver bug, and suggested filling a kernel bug entry, which is what I am doing now. The MythTV request is at http://code.mythtv.org/trac/ticket/8074.

Both MythTV and Kaffeine problems have also been seen by another user here:
http://godard.b.free.fr/dotclear/index.php?2007/04/04/13-hauppauge-wintv-hvr1300-under-linux#c1346

I use mainly Fedora kernel, but occasionally try also kernel.org vanilla kernels, so this is by no means specific to the Fedora kernel.
Comment 1 Rafael Varela Pet 2011-03-21 21:31:01 UTC
I can confirm that is not specific to Fedora kernels nor MythTV.

It happens the same with Kaffeine in my Debian Squeeze System (kernel 2.6.32-5-686-bigmem)

See:

http://bugs.debian.org/614285
https://bugs.launchpad.net/debian/+bug/439163
Comment 2 andrew.walker27 2011-03-23 23:46:33 UTC
Same problem here, my HVR-1300 used to work with MythTV and Kaffeine correctly until a kernel upgrade around about > 2.6.27 which since then has never worked correctly. I've read reports that increasing the time to lock channels prevents the timeouts but nothing seems to work now. I've also got a WinTV Nova-T card and whilst it's not the same chipset, I'm now getting the same problem with channels not being found. I'm fairly sure the problem is a kernel issue with v4l/v4l2, I got better results using v4l-hg tree but I'm using kernel 2.6.38 now and the problem is still there.

I'm using Gentoo but I've tried the HVR-1300 in the latest Mythbuntu 10.10 as well with the same result.
Comment 3 andrew.walker27 2011-04-01 21:43:05 UTC
Great, I've also got the same problem with my WinTV Nova-T card now.
Doesn't look like anyone is interested in fixing the problem either.
Comment 4 Damien Churchill 2011-04-06 22:48:29 UTC
(In reply to comment #2)
> Same problem here, my HVR-1300 used to work with MythTV and Kaffeine correctly
> until a kernel upgrade around about > 2.6.27 which since then has never worked
> correctly. I've read reports that increasing the time to lock channels prevents
> the timeouts but nothing seems to work now. I've also got a WinTV Nova-T card
> and whilst it's not the same chipset, I'm now getting the same problem with
> channels not being found. I'm fairly sure the problem is a kernel issue with
> v4l/v4l2, I got better results using v4l-hg tree but I'm using kernel 2.6.38
> now and the problem is still there.
> 

Applying the fix from comment 147 on the Launchpad link resolved the problem for me, I'm able to find channels using w_scan, scan and gstreamer now.
Comment 5 Alan 2012-08-14 15:44:05 UTC
Do you still need this workaround with modern kernels ?
Comment 6 Jan "Yenya" Kasprzak 2012-09-06 07:27:48 UTC
Alan: it works for me in Fedora 17 (distribution kernel 3.5.0-2.fc17.x86_64).
Comment 7 Alan 2012-09-06 10:50:48 UTC
thanks
Comment 8 Rafael Varela Pet 2012-09-30 09:15:21 UTC
Just for the record, it works for me in Debian Squeeze with a backported Kernel (3.2.0-0.bpo.3-amd64)

Note You need to log in before you can comment on or make changes to this bug.