Bug 2689 - ide: lost interrupt
Summary: ide: lost interrupt
Status: REJECTED DUPLICATE of bug 2665
Alias: None
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts (show other bugs)
Hardware: i386 Linux
: P2 blocking
Assignee: Bartlomiej Zolnierkiewicz
URL:
Keywords:
: 2695 2697 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-05-12 09:54 UTC by Marc poulhi
Modified: 2004-05-13 22:38 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.6
Tree: Mainline
Regression: ---


Attachments

Description Marc poulhi 2004-05-12 09:54:57 UTC
Distribution: debian sid
Hardware Environment: AMD Thunderbird with VIA KT333
Software Environment:
Problem Description:
When booting up, it keeps displaying 'hda: lost interrupt'

Steps to reproduce:
Just boot... Don't really know what else to give in order to help.

It is working well with kernel 2.6.6-rc3 and older.
Comment 1 Bartlomiej Zolnierkiewicz 2004-05-12 11:12:21 UTC
Does booting with "acpi=noirq" parameter help?
Comment 2 Marc poulhi 2004-05-13 01:19:49 UTC
Here's what i get when booting with acpi=noirq. I did copy/paste what i think is
relevant. The system seems to work, but i don't think these messages ;)


ide: Assuming 66MHz system bus speed for PIO modes
VP_IDE: IDE controller at PCI slot 0000:00:11.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: User given PCI clock speed impossible (66000), using 33 MHz instead.
VP_IDE: Use ide0=ata66 if you want to assume 80-wire cable.
VP_IDE: VIA vt8233a (rev 00) IDE UDMA133 controller on pci0000:00:11.1
    ide0: BM-DMA at 0x9800-0x9807, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x9808-0x980f, BIOS settings: hdc:pio, hdd:DMA
hda: Maxtor 6Y080P0, ATA DISK drive
Using anticipatory io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdd: Hewlett-Packard CD-Writer Plus 9100, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 160086528 sectors (81964 MB) w/7936KiB Cache, CHS=65535/16/63, UDMA(133)
 hda: hda1 hda2 hda3 < hda5 hda6 hda7 hda8 hda9 >
hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
hda: task_no_data_intr: error=0x04 { DriveStatusError }
hda: Write Cache FAILED Flushing!
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
Advanced Linux Sound Architecture Driver Version 1.0.4rc2 (Tue Mar 30 08:19:30 2
004 UTC).
ALSA device list:
  No soundcards found.
NET: Registered protocol family 2
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
NET: Registered protocol family 1
NET: Registered protocol family 17
NET: Registered protocol family 8
NET: Registered protocol family 20
PM: Reading pmdisk image.
hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
hda: task_no_data_intr: error=0x04 { DriveStatusError }
hda: Write Cache FAILED Flushing!
PM: Resume from disk failed.
ACPI: (supports S0 S1 S4 S5)
hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
hda: task_no_data_intr: error=0x04 { DriveStatusError }
hda: Write Cache FAILED Flushing!
hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
hda: task_no_data_intr: error=0x04 { DriveStatusError }
hda: Write Cache FAILED Flushing!
hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
hda: task_no_data_intr: error=0x04 { DriveStatusError }
hda: Write Cache FAILED Flushing!
XFS mounting filesystem hda2
Comment 3 Bartlomiej Zolnierkiewicz 2004-05-13 10:51:17 UTC
*** Bug 2695 has been marked as a duplicate of this bug. ***
Comment 4 Bartlomiej Zolnierkiewicz 2004-05-13 11:15:11 UTC
*** Bug 2697 has been marked as a duplicate of this bug. ***
Comment 5 Bartlomiej Zolnierkiewicz 2004-05-13 11:19:02 UTC
This is ACPI bug not IDE one.

[ although "Write Cache FAILED Flushing!" is an IDE bug #2672 ]
Comment 6 rocky.10.balboa 2004-05-13 12:42:01 UTC
Sorry I don't know about the nature of this problem. Anyway using both
"acpi=noirq" and "ide1=0x170,0x376,15" it works but I have to enable IRQ for VGA
from BIOS to see AGP working.
Comment 7 Len Brown 2004-05-13 22:37:02 UTC

*** This bug has been marked as a duplicate of 2665 ***

Note You need to log in before you can comment on or make changes to this bug.