Bug 26832 - Unable to regulate brightness
Unable to regulate brightness
Status: CLOSED DUPLICATE of bug 27702
Product: ACPI
Classification: Unclassified
Component: Power-Video
x86-64 Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-16 13:06 UTC by Ray Song
Modified: 2011-02-10 01:45 UTC (History)
2 users (show)

See Also:
Kernel Version: since 2.6.37-git11
Tree: Mainline
Regression: No


Attachments
dmesg output (110.00 KB, application/x-tar)
2011-01-16 13:06 UTC, Ray Song
Details

Description Ray Song 2011-01-16 13:06:12 UTC
Created attachment 43712 [details]
dmesg output

I am unable to regulate brightness with 2.6.37-git14. The same issue occurrs with 2.6.37-git11 too while 2.6.37-git9 and 2.6.37-git10 don't. The four configuation files are almost the same except for some minor changes generated by `make oldconfig'.

Here is `lspci | grep -i video':

02:00.0 VGA compatible controller: ATI Technologies Inc M92 [Mobility Radeon HD 4500 Series]
Comment 1 Zhang Rui 2011-01-18 01:11:01 UTC
how do you control the backlight?
hotkeys? or sysfs I/F?
does changing /sys/class/backlight/acpi_video0/brightness work for you?
Comment 2 Ray Song 2011-01-26 10:06:52 UTC
When the backlight control function is disabled, the /sys/class/backlight/ directory is empty.

Here is a snippet extracted from `dmesg':

pnp 00:06: [io  0x0070-0x0077]
pnp 00:06: Plug and Play ACPI device, IDs PNP0b00 (active)
pnp 00:07: [io  0x0060]
pnp 00:07: [io  0x0064]
pnp 00:07: [irq 1]
pnp 00:07: Plug and Play ACPI device, IDs PNP0303 (active)
pnp 00:08: [irq 12]
pnp 00:08: Plug and Play ACPI device, IDs DLL0404 PNP0f13 (active)
pnp 00:09: [irq 23]
pnp 00:09: Plug and Play ACPI device, IDs SMO8800 (active)
ACPI Exception: AE_ERROR, Returned by Handler for [PCI_Config] (20101209/evregion-474)
ACPI Error: Method parse/execution failed [\_SB_.PCI0.PDRC._CRS] (Node ffff880133a93a50), AE_ERROR (20101209/psparse-537)
ACPI Error: Method execution failed [\_SB_.PCI0.PDRC._CRS] (Node ffff880133a93a50), AE_ERROR (20101209/uteval-103)
pnp 00:0a: can't evaluate _CRS: 1
system 00:0a: Plug and Play ACPI device, IDs PNP0c02 (active)
pnp 00:0b: [bus ff]
pnp 00:0b: Plug and Play ACPI device, IDs PNP0a03 (active)
pnp: PnP ACPI: found 12 devices
ACPI: ACPI bus type pnp unregistered
Comment 3 Ray Song 2011-01-26 10:10:45 UTC
I have compiled a 2.6.38-rc2-git3 kernel while this issue remains.
Comment 4 Zhang Rui 2011-02-09 02:34:30 UTC
does this patch help?
https://patchwork.kernel.org/patch/499221/
Comment 5 Ray Song 2011-02-09 04:40:26 UTC
This patch works with 2.6.38-rc4. Thanks!
Comment 6 Zhang Rui 2011-02-10 01:45:00 UTC

*** This bug has been marked as a duplicate of bug 27702 ***

Note You need to log in before you can comment on or make changes to this bug.