Bug 26792 - Conflict between udev and the kernel which causes kernel panics on boot
Summary: Conflict between udev and the kernel which causes kernel panics on boot
Status: RESOLVED INVALID
Alias: None
Product: Other
Classification: Unclassified
Component: module-init-tools (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: Greg Kroah-Hartman
URL: https://bugs.archlinux.org/task/22343
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-15 11:35 UTC by Alex
Modified: 2012-02-22 21:55 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.36
Tree: Mainline
Regression: No


Attachments

Description Alex 2011-01-15 11:35:32 UTC
Sorry if this is a wrong thread to post it, this one is my first.

As some people discovered, there's a conflict between udev 165 and kernel 2.6.36 which causes kernel panics when boot or insert/eject optical media. The bug report was started on Arch tracker and it says that the problem is in new udev 165: https://bugs.archlinux.org/task/22343 . But later some messages were posted on Arch forum ( https://bbs.archlinux.org/viewtopic.php?pid=878331#p878331 ):

======

Did you do a mkinitcpio to put the downgraded version on the ramdisk? Try grepping your logs to see if 165 was still starting up. That's bitten me..

Keep in mind that this is not a udev bug. It's a kernel bug that udev165 tickles. Even after patching udev to eliminate the offending call so the system doesn't crash at boot I can still crash the machine any time I want to by running some test code (or standard utilities) a few times. It isn't necessarily a new bug or a regression either, it may have been around a while. It looks like you need an ATAPI device in your system to see it, and it may be just a subset of the ATAPI devices are affected. Intermittent crashes, hard to show real cause and effect, fun stuff to debug and fix.

======


https://bbs.archlinux.org/viewtopic.php?pid=878334#p878334 :

======

I just realized that running the kernel with 'edd=off' seems to allow me to boot now.  Only tried it a few times but I was getting 90% boot failure prior to this and I haven't not been able to boot yet.  Might help with some?!?!?!

======

There's also a screenshot of boot kernel panic on the page https://bugs.archlinux.org/task/22343 .
Comment 2 Greg Kroah-Hartman 2012-02-22 21:55:23 UTC
All udev bugs should be sent to the linux-hotplug@vger.kernel.org mailing 
list, and not entered into bugzilla.  Please bring this issue up there,
if it is still a problem in the latest kernel release.

Note You need to log in before you can comment on or make changes to this bug.