Bug 2669 - Too restrictive permissions on some files prevent non-root build (with KBUILD_OUTPUT)
Summary: Too restrictive permissions on some files prevent non-root build (with KBUILD...
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Adrian Bunk
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-10 11:10 UTC by Kalin KOZHUHAROV
Modified: 2005-07-02 19:26 UTC (History)
0 users

See Also:
Kernel Version: linux-2.6.6
Tree: Mainline
Regression: ---


Attachments

Description Kalin KOZHUHAROV 2004-05-10 11:10:22 UTC
Distribution: Gentoo-1.4 (non-distribution specific)
Hardware Environment: AthlonXP
Software Environment: gcc-3.3
Problem Description:Too restrictive permissions on some files prevent non-root
build (with KBUILD_OUTPUT)

Steps to reproduce:
cd /usr/src
tar xjf linux-2.6.6.tar.bz2
su normal_user
mkdir /tmp/test
export KBUILD_CONFIG=/tmp/test
make mrproper config
make

...
build fails because make cannot read for example:
/usr/src/linux-2.6.6/drivers/char/agp/isoch.c

To find all (most?) such files:
find /usr/src/linux-2.6.6 ! -perm -004 -exec ls -l {} \;

and to fix them:
find /usr/src/linux-2.6.6 ! -perm -004 -exec chmod o+r {} \;


Apparently this bug does not apply to "normal",i.e. root builds.
Comment 1 Kalin KOZHUHAROV 2004-05-10 11:12:00 UTC
Oops, forgot to include the actual output, i.e. the files that cause trouble...

# find /usr/src/linux-2.6.6 ! -perm -004 -exec ls -l {} \;
-rw-r-----    1 500      500          2546 May 10 11:32
/usr/src/linux-2.6.6/arch/arm/mm/tlb-v6.S
-rw-r-----    1 500      500          5018 May 10 11:31
/usr/src/linux-2.6.6/arch/arm/mm/cache-v6.S
-rw-r-----    1 500      500           516 May 10 11:31
/usr/src/linux-2.6.6/arch/arm/mm/abort-ev6.S
-rw-r-----    1 500      500          5924 May 10 11:31
/usr/src/linux-2.6.6/arch/arm/mm/proc-v6.S
-rw-r-----    1 500      500          4751 May 10 11:33
/usr/src/linux-2.6.6/arch/arm/mm/blockops.c
-rw-r-----    1 500      500          2273 May 10 11:32
/usr/src/linux-2.6.6/arch/arm/mm/copypage-v6.c
-rw-r-----    1 500      500         13235 May 10 11:33
/usr/src/linux-2.6.6/drivers/char/agp/isoch.c
-rw-r-----    1 500      500         17188 May 10 11:33
/usr/src/linux-2.6.6/drivers/input/joystick/grip_mp.c
-rw-r-----    1 500      500          1593 May 10 11:33
/usr/src/linux-2.6.6/Documentation/scsi/ChangeLog.megaraid
-rw-r-----    1 500      500          3106 May 10 11:33
/usr/src/linux-2.6.6/Documentation/networking/netif-msg.txt
Comment 2 Adrian Bunk 2005-07-02 19:26:34 UTC
This seems to be already fixed in recent 2.6 kernels.

Note You need to log in before you can comment on or make changes to this bug.