Bug 26202 - After upgrade to 2.6.37: display backlight is not controllable after first dpms dim
After upgrade to 2.6.37: display backlight is not controllable after first dp...
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 high
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2011-01-06 10:06 UTC by Jens Weibler
Modified: 2011-02-02 23:19 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37
Tree: Mainline
Regression: Yes


Attachments
Print more debugging info (1.24 KB, patch)
2011-01-11 02:50 UTC, Indan
Details | Diff

Description Jens Weibler 2011-01-06 10:06:59 UTC
I just upgraded to 2.6.37 (from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.37-natty/) and my display backlight can't be controlled any more after it's dimmed (dpms?).

It works just fine after booting with boot keys (Fn+Cursor Up/Down) and KDE Power Management Panel (Battery Settings - Screen Brightness Slider).

Both /sys/class/backlight/acpi_video0/(actual_brightness|brightness) return the current value. Setting acpi_video0/brightness shows no effect other than a changed value of actual_brightness and brightness.

Hardware:
Dell Latitude E6500
Intel GM45
Comment 1 Jens Weibler 2011-01-06 10:15:25 UTC
Just tested it: xset dpms force standy triggers it
I've attached my kern.log with drm.debug=0x07
Comment 2 Jens Weibler 2011-01-06 10:18:09 UTC
Uploadsize too small ;)
75MB bzipped to 2MB but I can only upload 1MB
Comment 3 Indan 2011-01-11 02:50:31 UTC
Created attachment 43232 [details]
Print more debugging info

Your attachment didn't make it.

Can you try this debugging patch and without drm.debug and post the result? (Or just drm.debug=0x02.) This is just to see if setting and getting the backlight works as it's suposed to.
Comment 4 Jens Weibler 2011-01-28 10:38:51 UTC
Seems to be fixed in 2.6.38 rc2

Note You need to log in before you can comment on or make changes to this bug.