Bug 26112 - [LogFS] [2.6.37-rc8+] Kernel BUG at logfs/readwrite.c:297!
[LogFS] [2.6.37-rc8+] Kernel BUG at logfs/readwrite.c:297!
Status: RESOLVED OBSOLETE
Product: File System
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: fs_other
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2011-01-04 20:17 UTC by Maciej Rutecki
Modified: 2012-08-14 15:23 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.37-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-01-04 20:17:35 UTC
Subject    : [LogFS] [2.6.37-rc8+] Kernel BUG at logfs/readwrite.c:297!
Submitter  : Prasad Joshi <prasadjoshi124@gmail.com>
Date       : 2011-01-02 21:22
Message-ID : AANLkTinpoM8FuG8UkF88xs_V37dz_wgE8t-s0JPzaS-w@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=129400335910652&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2011-02-20 14:32:37 UTC
Don't know... except for the obvious patch:

diff --git a/fs/logfs/readwrite.c b/fs/logfs/readwrite.c
index ee99a9f..8d51253 100644
--- a/fs/logfs/readwrite.c
+++ b/fs/logfs/readwrite.c
@@ -292,7 +292,7 @@ static void logfs_lock_write_page(struct page *page)
 
        while (unlikely(!trylock_page(page))) {
                if (loop++ > 0x1000) {
-                       /* Has been observed once so far... */
+                       /* Has been observed twice so far... */
                        printk(KERN_ERR "stack at %p\n", &loop);
                        BUG();
                }

Note You need to log in before you can comment on or make changes to this bug.