Bug 25842 - thinkpad T410s intel i915 regression
thinkpad T410s intel i915 regression
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 high
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-12-29 18:21 UTC by Travis Hume
Modified: 2010-12-30 22:32 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Travis Hume 2010-12-29 18:21:53 UTC
2.6.37-rc7 working great.

built 2.6.37-rc8 this morning and screen is unusable.  Off center to the right by about 200 px and very jittery.

Sorry for the overly technical description :)


Ubuntu 10.10
From lshw:

        *-display
             description: VGA compatible controller
             product: Core Processor Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 02
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:43 memory:f2000000-f23fffff memory:d0000000-dfffffff ioport:1800(size=8)
Comment 1 Gordon Jin 2010-12-30 00:32:50 UTC
Can you try if this regression is caused by the commit mentioned in https://bugs.freedesktop.org/show_bug.cgi?id=32698?
Comment 2 Travis Hume 2010-12-30 03:06:42 UTC
Success!! I reverted that commit and rebuilt.  Everything working great again.

git co v2.6.37-rc8
git revert 448f53a1ede54eb854d036abf54573281412d650
Finished one revert.
[detached HEAD b273081] Revert "drm/i915/bios: Reverse order of 100/120 Mhz SSC clocks"
 1 files changed, 1 insertions(+), 1 deletions(-)

Note You need to log in before you can comment on or make changes to this bug.