Bug 25822 - [BUG] kernel BUG at mm/truncate.c:479! on 2.6.37-rc8
[BUG] kernel BUG at mm/truncate.c:479! on 2.6.37-rc8
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-12-29 10:40 UTC by Maciej Rutecki
Modified: 2011-03-06 12:29 UTC (History)
8 users (show)

See Also:
Kernel Version: 2.6.37-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-12-29 10:40:58 UTC
Subject    : [BUG] kernel BUG at mm/truncate.c:479! on 2.6.37-rc8
Submitter  : Gurudas Pai <gurudas.pai@oracle.com>
Date       : 2010-12-29 6:58
Message-ID : 4D1AD935.1020504@oracle.com
References : http://marc.info/?l=linux-kernel&m=129360511222037&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Trond Myklebust 2010-12-29 18:25:54 UTC
This isn't anything to do with NFS. page mapping races definitely lie within the
bailiwick of the VM maintainers.

Reassigning...
Comment 2 Gurudas Pai 2011-01-20 06:50:31 UTC
Hi,
I have tested this with patch given by Hugh , and it worked for me. Patch is available in following location. Is this included in mainline ?
https://lkml.org/lkml/2010/12/29/131


Thanks.
Comment 3 Florian Mickler 2011-01-29 20:52:29 UTC
Andrew, did you get the patch from Miklos? (see  https://lkml.org/lkml/2011/1/20/122 for why I'm asking this) 

Patch: https://lkml.org/lkml/2010/12/29/131
Comment 4 Hugh Dickins 2011-02-03 21:00:40 UTC
Miklos's most recent patch for this is at:

https://lkml.org/lkml/2011/1/20/163

An executive summary of the thread that followed would be that hch dislikes the bloat, as we all do, but Miklos and I don't see a decent alternative (and hch has not proposed one).
Comment 5 Rafael J. Wysocki 2011-02-03 21:57:32 UTC
Patch : https://lkml.org/lkml/2011/1/20/163
Comment 6 Rafael J. Wysocki 2011-02-21 22:22:05 UTC
Handled-By : Miklos Szeredi <mszeredi@suse.cz>
Comment 7 Chuck Ebbert 2011-02-25 14:38:51 UTC
Fixed by commit 2aa15890f3c191326678f1bd68af61ec6b8753ec

Note You need to log in before you can comment on or make changes to this bug.