Bug 25812 - 2.6.37-rc7: Regression: b43: crashes in hwrng_register()
2.6.37-rc7: Regression: b43: crashes in hwrng_register()
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-12-29 10:28 UTC by Maciej Rutecki
Modified: 2011-01-15 13:11 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37-rc7
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-12-29 10:28:58 UTC
Subject    : 2.6.37-rc7: Regression: b43: crashes in hwrng_register()
Submitter  : "Mario 'BitKoenig' Holbe" <Mario.Holbe@tu-ilmenau.de>
Date       : 2010-12-28 13:32
Message-ID : slrnihjpnh.7t4.Mario.Holbe@darkside.dyn.samba-tng.org
References : http://marc.info/?l=linux-kernel&m=129354319002301&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2011-01-15 13:11:27 UTC
commit 0735ac1f2551d9f9d356126aaf3b1110150918e6
Author: Herbert Xu <herbert@gondor.apana.org.au>
Date:   Fri Jan 7 14:48:57 2011 +1100

    hwrng: via_rng - Fix asm constraints
    
    The inline asm to invoke xstore did not specify the constraints
    correctly.  In particular, dx/di should have been marked as output
    registers as well as input as they're modified by xstore.
    
    Thanks to Mario Holbe for creating this patch and testing it.
    
    Tested-by: Mario 'BitKoenig' Holbe <Mario.Holbe@TU-Ilmenau.DE>
    Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>

Note You need to log in before you can comment on or make changes to this bug.