Bug 2579 - ALSA ens_1370 module not working properly
ALSA ens_1370 module not working properly
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Other
i386 Linux
: P2 high
Assigned To: drivers_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-23 08:14 UTC by Patrizio Bassi
Modified: 2005-11-01 10:00 UTC (History)
0 users

See Also:
Kernel Version: all 2.6.x
Tree: Mainline
Regression: ---


Attachments

Description Patrizio Bassi 2004-04-23 08:14:40 UTC
Distribution: gentoo 
kernel versions: all 2.6.x versions 
alsa driver: all 1.0.x drivers, trying kernel included sources and external sources too. 
compilation: as module or as integrated too. 
 
cat .config |grep SND 
CONFIG_SND=m 
CONFIG_SND_TIMER=m 
CONFIG_SND_PCM=m 
CONFIG_SND_RAWMIDI=m 
CONFIG_SND_SEQUENCER=m 
CONFIG_SND_SEQ_DUMMY=m 
CONFIG_SND_OSSEMUL=y 
CONFIG_SND_MIXER_OSS=m 
CONFIG_SND_PCM_OSS=m 
CONFIG_SND_SEQUENCER_OSS=y 
CONFIG_SND_RTCTIMER=m 
CONFIG_SND_ENS1370=m 
 
 
pci bus report: 
 
lspci -v 
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03) 
        Flags: bus master, medium devsel, latency 64 
        Memory at e0000000 (32-bit, prefetchable) 
        Capabilities: [a0] AGP version 1.0 
 
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03) 
(prog-if 00 [Normal decode]) 
        Flags: bus master, 66Mhz, medium devsel, latency 64 
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64 
        I/O behind bridge: 0000d000-0000dfff 
        Memory behind bridge: db000000-dbefffff 
        Prefetchable memory behind bridge: dbf00000-dfffffff 
        Expansion ROM at 0000d000 [disabled] [size=4K] 
 
0000:00:04.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02) 
        Flags: bus master, medium devsel, latency 0 
 
0000:00:04.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80 
[Master]) 
        Flags: bus master, medium devsel, latency 32 
        I/O ports at b800 [size=16] 
 
0000:00:04.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00 
[UHCI]) 
        Flags: bus master, medium devsel, latency 32, IRQ 11 
        I/O ports at b400 [size=32] 
 
0000:00:04.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02) 
        Flags: medium devsel, IRQ 9 
 
0000:00:0b.0 Multimedia audio controller: Ensoniq ES1370 [AudioPCI] (rev 01) 
        Subsystem: Unknown device 4942:4c4c 
        Flags: bus master, slow devsel, latency 32, IRQ 10 
        I/O ports at b000 
 
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 RF/SG AGP (prog-if 
00 [VGA]) 
        Subsystem: ATI Technologies Inc Rage Fury/Xpert 128/Xpert 2000 
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 64, IRQ 11 
        Memory at dc000000 (32-bit, prefetchable) 
        I/O ports at d800 [size=256] 
        Memory at db000000 (32-bit, non-prefetchable) [size=16K] 
        Capabilities: [50] AGP version 2.0 
        Capabilities: [5c] Power Management version 1 
 
 
 
Problem Description: 
with 2.4.2x alsa drivers worked so good. 
now when i play sound, with every player, mplayer, xmms, kde stuff and so on.. 
i got a bad sound, with flicks, rumors and so on. 
 
i see that the noises are even worse when my secondary hard disk is used (ex. when playing a divs 
from that hd). disabling dma on that hark disk seems to reduce pretty to 0 the problem. 
 
i repeat i has this problem since i used 2.6.x kernel while 2.4.x worked good with a clean sound. 
Not a hardware problem cause in Windows or old kernel it still work good. 
as you can seem system reconizes my sound card as 1370. i tried 1371 module but it didn't work at 
all. 
 
so actually no solution.
Comment 1 Patrizio Bassi 2004-04-27 01:43:54 UTC
probably due to IDE busmastering and however a really buggy ide driver 
Comment 2 Patrizio Bassi 2004-09-15 23:54:54 UTC
still bugged on 2.6.9-rc2 
 
 
please fix!!! 
Comment 3 Patrizio Bassi 2004-12-05 07:52:09 UTC
still there in 2.6.9 and .10-rc3 too. 
 
even it a bit better..... 
Comment 4 Patrizio Bassi 2005-01-14 10:22:13 UTC
i confirm same bug for 2.6.10 and 2.6.11-rc1. 
 
Comment 5 Patrizio Bassi 2005-02-12 08:02:05 UTC
tried 2.6.11-rc3 and 2.6.11-rc3-bk9  
  
seems again a little better, but not perfect as 2.4 or windows 
 
come on fix that please!!!  
Comment 6 Patrizio Bassi 2005-02-22 09:55:57 UTC
rc4 bugged too. 
Comment 7 Patrizio Bassi 2005-10-26 03:13:52 UTC
2.6.14-rc* still bugged! 
 
do something please! 
Comment 8 Jaroslav Kysela 2005-10-26 03:19:58 UTC
It's not related to sound (except that the soundcard makes the problem visible),
but likely to ACPI or PCI bridge or IDE controller setup.
Comment 9 Patrizio Bassi 2005-10-31 07:27:35 UTC
stand bugged on 2.6.14 stable release 
Comment 10 Patrizio Bassi 2005-11-01 10:00:35 UTC
seems now i got it **pretty** fixed. 
 
what i did: 
1) updated kernel to 2.6.14-git4 
2) setted 100Hz instead of 250 
3) setted latency to 0x40 (64) instead of old 0x20 (32) 
4) disabled pci 2.1 in my bios. 
 
closing 

Note You need to log in before you can comment on or make changes to this bug.