Bug 25722 - (zram) regression: zram stopped working in 2.6.37-rc
(zram)
regression: zram stopped working in 2.6.37-rc
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Staging
All Linux
: P1 normal
Assigned To: drivers_staging@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-27 15:04 UTC by Dennis Jansen
Modified: 2013-10-04 19:45 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.37-rc
Tree: Mainline
Regression: Yes


Attachments

Description Dennis Jansen 2010-12-27 15:04:53 UTC
Data written to zram is not retained in 2.6.37. It worked fine before. So we've got a regression that stops it from working. 

There is a bug filed for this issue here as well:
http://code.google.com/p/compcache/issues/detail?id=78

It would of course be nice to release 2.6.37 with a working zram module.
Looking over the changes, it doesn't seem like the problem comes from a change in zram's code: http://bit.ly/i3HrXr, but rather out of the zram staging tree. This means it could be related to other bugs.
Comment 1 Nitin Gupta 2010-12-30 00:40:29 UTC
The fix was posted to LKML but didn't get much attention probably due to holiday season: https://lkml.org/lkml/2010/12/27/155

Please let me know if you still find any problems.

Nitin
Comment 2 Dennis Jansen 2010-12-30 08:50:32 UTC
I can't compile right now. Try sending it directly to Linus, hopefully it can make it into the final release. Can hardly be worse than not working at all...

Dennis
Comment 4 Ken Sharp 2013-10-04 19:45:42 UTC
Could someone with access removed the zram alias from this bug? It affects all searches.

Note You need to log in before you can comment on or make changes to this bug.