Bug 25562 - Backlight settings lost when changing monitor resolution.
Backlight settings lost when changing monitor resolution.
Status: RESOLVED DUPLICATE of bug 22672
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-23 17:17 UTC by anxuiz.nx
Modified: 2011-01-12 19:49 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.37-rc7
Tree: Mainline
Regression: No


Attachments
lspci -vvv (18.29 KB, text/plain)
2010-12-23 17:17 UTC, anxuiz.nx
Details
/proc/config.gz (unzipped) (70.34 KB, text/plain)
2010-12-23 17:19 UTC, anxuiz.nx
Details

Description anxuiz.nx 2010-12-23 17:17:36 UTC
Created attachment 41532 [details]
lspci -vvv

When changing the resolution of my monitor from the native resolution (1280 x 800) to a smaller resolution, the backlight on my monitor is set to the lowest possible and an error appears in /var/log/errors.log:

Dec 23 09:10:47 arch-laptop kernel: [ 1635.188107] [drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.

The backlight settings are restored correctly and no error appears when changing from a non native resolution to the native resolution.

I am running Arch Linux with GNOME on a Gateway MT6707 with an Intel GMA 945 Graphics and the i915 kernel DRM module.

I am running the latest git tree kernel using a custom configuration which is attached.
Comment 1 anxuiz.nx 2010-12-23 17:19:56 UTC
Created attachment 41542 [details]
/proc/config.gz (unzipped)
Comment 2 anxuiz.nx 2010-12-23 17:29:38 UTC
Steps to reproduce:

$ gnome-display-properties
Set "Resolution" to a lower resolution than 1280 x 800.
Click "Apply"

The resulting backlight is at the lowest setting and two "bars" appears on the left and right side of the screen while the imagine is scaled between them.
Comment 3 anxuiz.nx 2010-12-23 19:24:17 UTC
It appears that the problem is this:

[drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.

From /var/log/kernel.log
Comment 4 Chris Wilson 2011-01-12 19:49:47 UTC

*** This bug has been marked as a duplicate of bug 22672 ***

Note You need to log in before you can comment on or make changes to this bug.