Bug 25522 - Kernel doe not shutdown on dell E6400
Kernel doe not shutdown on dell E6400
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-12-23 09:41 UTC by Eric Valette
Modified: 2011-02-18 18:02 UTC (History)
14 users (show)

See Also:
Kernel Version: 2.6.37-rc7
Tree: Mainline
Regression: Yes


Attachments
boot dmesg (63.65 KB, application/octet-stream)
2011-01-03 10:54 UTC, Eric Valette
Details
lspci (2.14 KB, application/octet-stream)
2011-01-03 10:55 UTC, Eric Valette
Details
Kernel config (71.58 KB, application/octet-stream)
2011-01-03 10:56 UTC, Eric Valette
Details
dmidecode (14.44 KB, application/octet-stream)
2011-01-03 10:58 UTC, Eric Valette
Details
call trace screen shot (246.68 KB, image/jpeg)
2011-01-31 15:12 UTC, lyman
Details
Bisect (688 bytes, text/plain)
2011-02-17 20:32 UTC, Joakim
Details

Description Eric Valette 2010-12-23 09:41:38 UTC
I tested two shutdown (one stay blocked one night and the other did not finish as well)

I have the following messages:

Will now halt
hub:4-0:1.0: hub_port_status_failed (err 110) repeated twice

My config did not change for almost one year...
Comment 1 Eric Valette 2010-12-23 22:33:55 UTC
As I use ketchup to update my source tree, to be sure I did a make mroper in the buildir and the source dir and rebuild from scratch.

The USB error message vanished but the hang is still there (2 hangs out of 3 shutdowns).

I cannot supply any more info as I have no more access to the problematic computer for more than a week.

I tried on othr compuers but I do not have the hang.
Comment 2 Eric Valette 2011-01-03 10:54:54 UTC
Created attachment 42192 [details]
boot dmesg
Comment 3 Eric Valette 2011-01-03 10:55:42 UTC
Created attachment 42202 [details]
lspci

Machine hardware.
Comment 4 Eric Valette 2011-01-03 10:56:16 UTC
Created attachment 42212 [details]
Kernel config
Comment 5 Eric Valette 2011-01-03 10:58:09 UTC
Created attachment 42222 [details]
dmidecode
Comment 6 Eric Valette 2011-01-03 10:58:59 UTC
Still fails on rc_-git2
Comment 7 Eric Valette 2011-01-06 09:12:57 UTC
Present in 2.6.37. I upgraded the BIOS to latest available just in case it does something with ACPI but no chnage.
Comment 8 Kornel Lugosi 2011-01-06 10:24:42 UTC
I have a lenovo 3000 n200 and the bug present at me also from rc2. It's still happening on 2.6.37 stable, but it only happens ~4 out of 5 times.

I don't see any messages like "hub:4-0:1.0: hub_port_status_failed (err 110)", it's totally silent.
The SysRq keys are not working at all.

I can also attach my configs if you want, but if I'll have time I'll try to bisect, and report back.
Comment 9 Kornel Lugosi 2011-01-06 10:26:37 UTC
I forgot to mention that I'm on x64, so it's not 386 specific.
Comment 10 Victor Naumov 2011-01-11 12:25:57 UTC
Confirm, NB Samsung X120 (X86_64) doesn't shutdown.
Comment 11 Ozan Caglayan 2011-01-22 16:12:26 UTC
Asus N61JQ hangs at shutdown too.
Comment 12 lyman 2011-01-31 15:04:55 UTC
Confirm, Fujitsu S6410/S6510
Comment 13 lyman 2011-01-31 15:12:57 UTC
Created attachment 45652 [details]
call trace screen shot

seconds after power off, some debug info printed on screen, and here's the screen shot.

archlinux x86_64.
Comment 14 Anton 2011-02-04 14:01:43 UTC
Confirm, Toshiba Satellite A200-1N1, x86_64.
Comment 15 Mario Garces 2011-02-07 13:38:48 UTC
(In reply to comment #13)
> Created an attachment (id=45652) [details]
> call trace screen shot
> 
> seconds after power off, some debug info printed on screen, and here's the
> screen shot.
> 
> archlinux x86_64.

same issue on HP 420 laptop (arch x86_64)
Comment 16 Mario Garces 2011-02-07 13:39:50 UTC
(In reply to comment #13)
> Created an attachment (id=45652) [details]
> call trace screen shot
> 
> seconds after power off, some debug info printed on screen, and here's the
> screen shot.
> 
> archlinux x86_64.

same issue on HP 420 laptop (arch x86_64)
Comment 17 James Sharam 2011-02-08 15:28:25 UTC
Exact same issue with almost exact same error as lyman.

Running Arch Linux 2.6.37-ARCH x86_64
Comment 18 James Sharam 2011-02-08 15:29:23 UTC
Sorry, probably should add: Problem occurs on my Acer 1420p laptop.
Comment 19 jw.hendy 2011-02-10 16:49:39 UTC
I can confirm.
,---
|Linux bigBang 2.6.37-ARCH #1 SMP PREEMPT Sat Jan 29 20:00:33 CET 2011 x86_64
|Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz GenuineIntel GNU/Linux
`---

I'm on an HP6910p laptop.
Comment 20 Rafael J. Wysocki 2011-02-14 22:16:27 UTC
Can any of you run "git bisect" of commits between 2.6.36 and 2.6.37 to find
that introduced the problem (if the problem is 100% reproducible, that should
be readily doable)?
Comment 21 Kornel Lugosi 2011-02-15 09:54:02 UTC
At me it's not 100% reproducible, it's around 50% on average.
Comment 22 jw.hendy 2011-02-15 17:17:15 UTC
@Rafael: same for me (not 100% reproducible). It actually hasn't happened since last week, though it did 3 shutdowns in a row, I believe. It has not happened this week yet.
Comment 23 Joakim 2011-02-15 19:48:24 UTC
For me it's 100% reproducible. I've also started a bisect though it will take a while to finish. It takes about 25 minutes for a clean build. Maybe I should try with a custom config to speed things up.
Comment 24 Eric Valette 2011-02-17 13:13:57 UTC
For me its one out of 5 (once per week). Not really eassy to bisect.
Comment 25 Joakim 2011-02-17 20:32:33 UTC
Created attachment 48222 [details]
Bisect

a3c08e5d80c54e32423efbba113b02942c91f726 is the first bad commit
Comment 26 Rafael J. Wysocki 2011-02-17 21:43:41 UTC
First-Bad-Commit : a3c08e5d80c54e32423efbba113b02942c91f726
Comment 27 Rafael J. Wysocki 2011-02-17 23:29:10 UTC
Can you please check if the problem is fixed by

commit 5117348dea5e3ecbb785cfa1271386fb49332b41
Author: Thomas Gleixner <tglx@linutronix.de>
Date:   Sat Feb 12 11:51:03 2011 +0100

    x86: Readd missing irq_to_desc() in fixup_irq()

(from the Linus' tree)?
Comment 28 Joakim 2011-02-18 13:02:25 UTC
Yes, it was fixed (for me at least) since v2.6.38-rc5. The fix must have been pulled into the tree a few hours after I started bisecting :(
Comment 29 Joakim 2011-02-18 13:03:03 UTC
Yes, it was fixed (for me at least) since v2.6.38-rc5. The fix must have been pushed into the tree a few hours after I started bisecting :(

Note You need to log in before you can comment on or make changes to this bug.