Bug 2552 - Hardlock running hdparm on kernel linux-2.6.5-mm6 (nforce2)
Summary: Hardlock running hdparm on kernel linux-2.6.5-mm6 (nforce2)
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386 (show other bugs)
Hardware: i386 Linux
: P2 blocking
Assignee: Zwane Mwaikambo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-20 19:50 UTC by Gerald J. Normandin jr.
Modified: 2004-11-30 23:25 UTC (History)
3 users (show)

See Also:
Kernel Version: linux-2.6.5-mm6
Tree: Mainline
Regression: ---


Attachments
working.diff (1.57 KB, patch)
2004-04-23 08:01 UTC, Eric Sandall
Details | Diff
Working .config file (30.79 KB, application/octet-stream)
2004-04-23 16:24 UTC, Gerald J. Normandin jr.
Details

Description Gerald J. Normandin jr. 2004-04-20 19:50:53 UTC
Distribution:
Gentoo Linux
Hardware Environment:
Amd AthlonXP 1800+
768 Megs Pc2100
Abit Nf7-s v2 (Nforce2)
Software Environment:
gcc version 3.3.2
linux-2.6.5-mm6
hdparm v5.4
Problem Description:
Hard Lock running hdparm -t /dev/hda


Steps to reproduce:
Fire up console
login as root
type hdparm -t /dev/hda
Watch in disbelief as system hardlocks
Comment 1 Gerald J. Normandin jr. 2004-04-20 20:09:28 UTC
Also, only other kernel attempted, is my current running kernel,  2.6.3-rc2-mm1.
No lockups whatsoever, if that helps. It's the only other kernel i've found to
be stable on this board.
Comment 2 Gerald J. Normandin jr. 2004-04-21 13:22:59 UTC
only other 2.6 kernel, I might add.
Comment 3 Mattia 2004-04-21 13:26:45 UTC
Same problem:
Distribution: Debian unstable
Hardware Environment:
AMD AthlonXP 3000+
1GB ram
Abit Nf7-S (nvidia Nforce2)
hda: Maxtor 6Y160P0
hde: Maxtor 6Y200M0 (sata)
Software Environment:
gcc version 3.3.3 (Debian 20040306)
linux-2.6.5 + bootsplash patch
hdparm v5.5
reiserfsck 3.6.14

I have an hardlock if I run hdparm -t /dev/hde (the serial ata), but NOT if I
run hdparm -t /dev/hda
My system also freeze if I run reiserfsck /dev/hde2 (sata) but NOT if I run
reiserfsck /dev/hda2 (root partition).
I have no problem with linux-2.6.3
Comment 4 Gerald J. Normandin jr. 2004-04-21 15:31:25 UTC
woohoooooo!
Looks like I might have fixed the issue...
I realized there was one critical difference in my kernel configurations: the
2.6.3 was configured as SMP, the 2.6.5 was not. I configured 2.6.5 to be SMP,
bam hdparm works great:
root@screamer gerrynjr # hdparm -t /dev/hda
 
/dev/hda:
 Timing buffered disk reads:  154 MB in  3.04 seconds =  50.72 MB/sec

interesting...
Comment 5 Mattia 2004-04-21 19:34:46 UTC
Bingo!
I set SMP to yes and now it works!
Thank you very much.

Both hdparm and reiserfsck dont freeze!

I hope there is no problem running a smp-kernel on a mono-processor system...

Bye!
Comment 6 Young-Ho Cha 2004-04-22 19:04:15 UTC
did you check http://atlas.et.tudelft.nl/verwei90/nforce2/ ?

there are good solutions for nforce2 chipset.
Comment 7 Eric Sandall 2004-04-22 19:07:39 UTC
I didn't try the patches, but using 'noapic' or 'acpi=off' did not help; I am
recompiling now to see if this works.
Comment 8 Len Brown 2004-04-23 07:47:44 UTC
somebody please attach a .config that hangs and the diff
with the one that does not.  I've been unable to get
my nforce2 to hang.  TIA.
Comment 9 Eric Sandall 2004-04-23 08:01:17 UTC
Created attachment 2674 [details]
working.diff

Here is a diff of what freezes on my system (2.6.5.cfg) with noapic and
acpi=off and what works (2.6.5.smp.cfg) without turning anything off. With the
first, turning off those options gets my machine to stay alive longer, but not
if I try to do any I/O (my disk seems to "freeze" with the activity light on).
I left the machine on overnight with the second config and it still seems okay.
I'm now doing some recompiles to put it through some tests, so we'll see (it
did some compiles overnight, too). So far so good. :)
Comment 10 Gerald J. Normandin jr. 2004-04-23 16:24:21 UTC
Created attachment 2678 [details]
Working .config file

This is my working .config file.
Comment 11 Eric Sandall 2004-04-28 08:57:47 UTC
My machine hasn't yet died in the last 4 days and that's with playing Never
Winter Nights, Unreal Tournament 2004, and doing several compiles. Vanilla 2.6.5
with SMP (instead of IO-APIC with Local-APIC).
Comment 12 Gerald J. Normandin jr. 2004-04-28 12:50:45 UTC
No issues here as well
Comment 13 Eric Sandall 2004-04-28 17:03:25 UTC
With using SMP, right (just for clarification ;))?
Comment 14 Wayne Mckinney 2004-05-14 10:19:59 UTC
	I started having the same issue as you with 2.6.6. 2.6.4 was rock stable. I
never tried 2.6.5. My system often hard locks on boot. when the system dose not
lock on boot it locks on disk access. ls /usr/bin or hdpram. Have you tried
2.6.6 yet; If so what happen? My system A7N8X Mainboard, 2500+, Promise
Ultra100TX2 hard drive controller, and WDC WD1200BB-00DAA3 hard drive.
Comment 15 Eric Sandall 2004-05-14 10:23:58 UTC
I haven't tried 2.6.6 yet, but did you try enabling SMP and see if that fixed it?
Comment 16 Zwane Mwaikambo 2004-11-30 23:25:13 UTC
The SMP kernels unconditionally enable the IOAPIC and Local-APIC, regardless,
this bug should be fixed in current kernels with the various nForce2 IOAPIC fixes.

Note You need to log in before you can comment on or make changes to this bug.