Bug 25502 - [945GM] Black screen shortly after startup
[945GM] Black screen shortly after startup
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Console/Framebuffers
All Linux
: P1 normal
Assigned To: James Simmons
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-23 03:13 UTC by celejar
Modified: 2014-08-05 11:45 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.37-rc6-lizzie-00132-g55ec86f
Tree: Mainline
Regression: No


Attachments
Kernel config (builtin) (72.69 KB, text/plain)
2010-12-23 03:13 UTC, celejar
Details
Kernel config (modular) (72.59 KB, text/plain)
2010-12-23 03:14 UTC, celejar
Details

Description celejar 2010-12-23 03:13:29 UTC
Created attachment 41422 [details]
Kernel config (builtin)

With a recent kernel (from mainline git repo), my system boots fine, but
shortly into the boot process, the screen goes, and remains, black.  This
occurs well out of the bootloader, but I'm not sure exactly where in the normal
linux startup it's happening.

There's apparently no GPU hang, since the boot apparently finishes normally,
and I can get a perfectly normal X session by blindly typing 'startx'.

My normal kernel config has AGP / DRM / Intel / Consoleframebuffer stuff (along
with just about everything else possible) built as modules.  When I switched
that whole chain to builtin, the system comes up fine, without the black
screen.

# 'lscpi -v'

...

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML
Express Integrated Graphics Controller (rev 03)
    Subsystem: Acer Incorporated [ALI] Device 0090
    Flags: bus master, fast devsel, latency 0
    Memory at d0180000 (32-bit, non-prefetchable) [size=512K]
    Capabilities: [d0] Power Management version 2


# 'uname -a'

Linux lizzie 2.6.37-rc6-lizzie-00132-g55ec86f #31 Mon Dec 20 16:45:00 EST 2010
i686 GNU/Linux

Debian Sid, on an Acer Aspire 3690

I'm attaching the two kernel configs.
Comment 1 celejar 2010-12-23 03:14:12 UTC
Created attachment 41432 [details]
Kernel config (modular)
Comment 2 Alan 2012-08-14 15:03:14 UTC
Is this still seen on 3.2/3.4 era kernels ?
Comment 3 celejar 2012-08-15 16:26:37 UTC
I don't remember whether the problem ever went away, but in any event, the original machine has been decommissioned, so I cannot answer the question; sorry.
Comment 4 Alan 2012-08-15 16:27:43 UTC
Thanks I'll close the bug as obsolete as the driver has changed a lot since then
Comment 5 itswu.alex 2014-08-04 06:47:53 UTC
Hi, I know this bug was closed a while ago but I can confirm that it still exists on the 3.2 kernel (fresh debian7 install).
Comment 6 Alan 2014-08-05 11:45:38 UTC
Please open a new bug for it

Note You need to log in before you can comment on or make changes to this bug.