Bug 25472 - snd_hda_intel does not work with IDT 92HD73C1X in Dell Studio 1558
snd_hda_intel does not work with IDT 92HD73C1X in Dell Studio 1558
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-12-22 18:42 UTC by Scott Chevalley
Modified: 2010-12-29 22:57 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37-rc7
Tree: Mainline
Regression: Yes


Attachments
lspci --vv to show hardware (53.17 KB, application/octet-stream)
2010-12-22 18:42 UTC, Scott Chevalley
Details
Fix patch #1 (1.40 KB, patch)
2010-12-23 09:27 UTC, Takashi Iwai
Details | Diff
Fix patch #2 (3.58 KB, patch)
2010-12-23 09:27 UTC, Takashi Iwai
Details | Diff

Description Scott Chevalley 2010-12-22 18:42:46 UTC
Created attachment 41362 [details]
lspci --vv to show hardware

starting with the 2.6.37-rc set of kernels, the internal soundcard does not get initialized properly.  Under 2.6.36.2 it works fine.

When booting with a 2.6.37 series kernel this line appears in dmesg:

hda_codec: cannot build controls for #0 (error -16)

and alsamixer says it cannot find any controls for that device.

I have tried adding:

options snd-hda-intel model=dell-m6

to /etc/modprobe.d/alsa-base but it makes no difference (based on a website I found).  I also tried adding pci=nomsi based on another comment, but that also doesn't work.

attached is lspci -vv from my system.  I'm currently running Mandriva Cooker x86_64.
Comment 1 Takashi Iwai 2010-12-22 20:30:00 UTC
Likely a dup of bug 25002.
This should have been fixed in 2.6.37-rc7.  Give it a try.
Comment 2 Scott Chevalley 2010-12-22 21:17:05 UTC
I'm currently booted with 2.6.37-rc7 and still see the issue.  I looked at bug 25002 and I'm not seeing the same log messages as stated there. 

When I load snd_hda_intel after unloading it I just see this:

Dec 22 16:06:00 excalibur64 kernel: HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
Dec 22 16:06:00 excalibur64 kernel: hda_codec: cannot build controls for #0 (error -16)


If there's a way to get more debugging-like info during the module load, I'm willing to try.
Comment 3 Takashi Iwai 2010-12-23 06:21:37 UTC
Then could you give the output of alsa-info.sh (run with --no-upload option), and attach it for further analysis?  See Documentation/sound/alsa/HD-Audio.txt for details.
Comment 4 Takashi Iwai 2010-12-23 09:26:10 UTC
Also, try the following two patches.  These are not in sound git tree.
Comment 5 Takashi Iwai 2010-12-23 09:27:20 UTC
Created attachment 41482 [details]
Fix patch #1
Comment 6 Takashi Iwai 2010-12-23 09:27:44 UTC
Created attachment 41492 [details]
Fix patch #2
Comment 7 Scott Chevalley 2010-12-23 16:03:20 UTC
Those patches do appear to fix the problem.  The kernel now configures the sound card correctly and sound plays fine.

Thanks!
Comment 9 Rafael J. Wysocki 2010-12-29 22:57:34 UTC
Fixed by commit 2d7ec12 ALSA: hda - Fix conflict of d-mic capture volume controls .

Note You need to log in before you can comment on or make changes to this bug.