Bug 25442 - ixp4xx defines FREQ macro; conflicts with gspca/ov519 driver
ixp4xx defines FREQ macro; conflicts with gspca/ov519 driver
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: ARM
All Linux
: P1 normal
Assigned To: linux-arm-kernel@lists.arm.linux.org.uk
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-12-22 02:02 UTC by Ben Hutchings
Modified: 2011-02-12 23:10 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37-rc5
Tree: Mainline
Regression: Yes


Attachments
patch to rename FREQ macro (2.62 KB, patch)
2010-12-22 02:02 UTC, Ben Hutchings
Details | Diff

Description Ben Hutchings 2010-12-22 02:02:42 UTC
Created attachment 41252 [details]
patch to rename FREQ macro

When building for the ARM IXP4xx platform, <linux/timex.h> ends up including
arch/arm/mach-ixp4xx/include/mach/timex.h which defines the macro FREQ.  This conflicts with use of FREQ as an enumerator in drivers/media/video/gspca/ov519.c.

Since the macro is platform-specific, its name really ought to be given a suitable prefix to avoid such conflicts.

Previously reported with patch at
<http://article.gmane.org/gmane.linux.ports.arm.kernel/99147>
Comment 1 Andrew Morton 2010-12-22 02:17:08 UTC
Please don't send patches via bugzilla - it causes lots of problems with
our usual patch management and review processes.

Please send this patch via email as per Documentation/SubmittingPatches. 
Suitable recipients may be found via scripts/get_maintainer.pl.  Please
also cc myself on the email.

Thanks.
Comment 2 Ben Hutchings 2010-12-22 03:02:25 UTC
(In reply to comment #1)
> Please don't send patches via bugzilla - it causes lots of problems with
> our usual patch management and review processes.

As I said, the patch was already sent by mail; I'm just repeating it here.
Comment 3 Rafael J. Wysocki 2010-12-22 12:18:02 UTC
Patch : https://bugzilla.kernel.org/attachment.cgi?id=41252
Handled-By : Ben Hutchings <ben@decadent.org.uk>
Comment 4 Rafael J. Wysocki 2011-02-12 23:10:43 UTC
Fixed by commit e66a022a80d73b1a5d2e02c9db2c42e8b9853b40 .

Note You need to log in before you can comment on or make changes to this bug.