Bug 25432 - Alpha fails to build with gcc 4.4
Alpha fails to build with gcc 4.4
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: Alpha
All Linux
: P1 normal
Assigned To: Richard Henderson
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-12-22 01:55 UTC by Ben Hutchings
Modified: 2011-02-09 04:59 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.37-rc5
Tree: Mainline
Regression: Yes


Attachments
x (1.65 KB, patch)
2010-12-22 02:15 UTC, Andrew Morton
Details | Diff

Description Ben Hutchings 2010-12-22 01:55:28 UTC
This seems to be well-known but is not yet on the regression list.

When building the kernel for alpha using gcc 4.4, many files will provoke these warnings:

arch/alpha/include/asm/io.h: In function '__set_hae':
arch/alpha/include/asm/io.h:41: warning: 'arch_local_irq_save' is static but used in inline function '__set_hae' which is not static
arch/alpha/include/asm/io.h:49: warning: 'arch_local_irq_restore' is static but used in inline function '__set_hae' which is not static

and because the alpha makefiles include -Werror in CFLAGS, this is fatal.
Comment 1 Andrew Morton 2010-12-22 02:15:54 UTC
Created attachment 41262 [details]
x
Comment 2 Andrew Morton 2010-12-22 02:16:06 UTC
How's that look?
Comment 3 Ben Hutchings 2010-12-22 03:00:06 UTC
(In reply to comment #2)
> How's that look?

I don't think it's as simple as that - there are a lot of callers to set_hae() that would also need to be static inline.

Here's the discussion thread I found:
http://thread.gmane.org/gmane.linux.ports.alpha/1218
Comment 4 Andrew Morton 2010-12-22 07:06:26 UTC
Well what does "extern inline logic is crucial for generic kernel build" mean?

The alpha kernel builds and links OK for me with that patch and older gcc.
Comment 5 Rafael J. Wysocki 2011-02-08 09:19:38 UTC
On Tuesday, February 08, 2011, Michael Cree wrote:
> On 03/02/11 13:05, Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.36 and 2.6.37.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=25432
> > Subject		: Alpha fails to build with gcc 4.4
> > Submitter	: Ben Hutchings<ben@decadent.org.uk>
> > Date		: 2010-12-22 01:55 (43 days old)
> 
> Fixed by commit e2609f6aa2dce5d960ea1fe32f57524c315dede5.
> 
> Cheers
> Michael.
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
> 
>
Comment 6 Florian Mickler 2011-02-09 04:58:45 UTC
fix merged in .38-rc1 :
commit e2609f6aa2dce5d960ea1fe32f57524c315dede5
Author: Ivan Kokshaysky <ink@jurassic.park.msu.ru>
Date:   Wed Jan 12 00:37:25 2011 -0500

    alpha: fix breakage caused by df9ee29270

Note You need to log in before you can comment on or make changes to this bug.