Bug 25312 - Blanked screen with 2.6.37-rc6, -rc5 works OK (bisected to 541cc966915b6756e54c20eebe60ae957afdb537)
Blanked screen with 2.6.37-rc6, -rc5 works OK (bisected to 541cc966915b6756e5...
Status: RESOLVED DUPLICATE of bug 25242
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-20 15:41 UTC by Alex Villacis Lasso
Modified: 2010-12-22 12:44 UTC (History)
1 user (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: Yes


Attachments
lspci -vvvv on the affected machine. (9.61 KB, text/plain)
2010-12-20 15:42 UTC, Alex Villacis Lasso
Details
Kernel configuration used to compile affected kernel (110.72 KB, application/octet-stream)
2010-12-20 15:43 UTC, Alex Villacis Lasso
Details

Description Alex Villacis Lasso 2010-12-20 15:41:03 UTC
All mentioned computers run Fedora 14 x86_64 with KMS.

On my work machine with an Intel graphics chipset and a flat panel with working EDID, vanilla kernels 2.6.37-rc6 and 2.6.37-rc5 works OK.

On my home machine, with a somewhat different Intel graphics chipset, and a flat panel that does *not* report EDID information, 2.6.37-rc5 works OK but 2.6.37-rc6 blanks the KMS display on boot. I get the "no signal" message on the panel instead of a working display. I was able to bisect this to the following commit:

commit 541cc966915b6756e54c20eebe60ae957afdb537
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Mon Dec 6 11:24:07 2010 +0000

    drm: Don't try and disable an encoder that was never enabled
    
    Prevents code that assumes that the encoder is active when asked to be
    disabled from dying a horrible death.
    
    Reported-by: Daniel Vetter <daniel.vetter@ffwll.ch>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Signed-off-by: Dave Airlie <airlied@redhat.com>

When I revert this commit, the problem goes away in my home machine.
Comment 1 Alex Villacis Lasso 2010-12-20 15:42:38 UTC
Created attachment 41012 [details]
lspci -vvvv on the affected machine.
Comment 2 Alex Villacis Lasso 2010-12-20 15:43:13 UTC
Created attachment 41022 [details]
Kernel configuration used to compile affected kernel
Comment 3 Alex Villacis Lasso 2010-12-20 15:49:06 UTC
Created freedesktop.org bug https://bugs.freedesktop.org/show_bug.cgi?id=32527
Comment 4 Chris Wilson 2010-12-22 12:44:37 UTC

*** This bug has been marked as a duplicate of bug 25242 ***

Note You need to log in before you can comment on or make changes to this bug.