Bug 25242 - [BUG] i915 boot got black screen with 2.6.37-rc5+
[BUG] i915 boot got black screen with 2.6.37-rc5+
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
: 25312 (view as bug list)
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-12-19 20:41 UTC by Maciej Rutecki
Modified: 2011-01-27 10:19 UTC (History)
10 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-12-19 20:41:27 UTC
Subject    : [BUG] i915 boot got black screen with 2.6.37-rc5+
Submitter  : Hui Zhu <teawater@gmail.com>
Date       : 2010-12-15 00:34
Message-ID : AANLkTimOOmFqxU=r+-RphdfPJ54Qr+6LHU60Grzpnerr@mail.gmail.com
References : http://www.mail-archive.com/stable@linux.kernel.org/msg01384.html

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Chris Wilson 2010-12-20 10:11:51 UTC
It seems like commit 541cc966 is the culprit:

commit 541cc966915b6756e54c20eebe60ae957afdb537
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Mon Dec 6 11:24:07 2010 +0000

    drm: Don't try and disable an encoder that was never enabled
    
    Prevents code that assumes that the encoder is active when asked to be
    disabled from dying a horrible death.

"Revert 541cc966915b6756e54c20eebe60ae957afdb537, every thing is OK."
Comment 2 Woody Suwalski 2010-12-20 13:59:57 UTC
Confirm, reverting the commit 541cc966915b6756e54c20eebe60ae957afdb537 fixes the problem on my G33 system
Comment 3 Jiri Slaby 2010-12-21 08:37:39 UTC
(In reply to comment #2)
> Confirm, reverting the commit 541cc966915b6756e54c20eebe60ae957afdb537 fixes
> the problem on my G33 system

For me too.
Comment 4 Stefan Dirsch 2010-12-21 15:33:33 UTC
(In reply to comment #2)
> Confirm, reverting the commit 541cc966915b6756e54c20eebe60ae957afdb537 fixes
> the problem on my G33 system

For me too on *SandyBridge*.
Comment 5 Hui Zhu 2010-12-22 05:16:48 UTC
Sorry for late.
My part is OK too.  That is great!
Comment 6 Chris Wilson 2010-12-22 12:44:37 UTC
*** Bug 25312 has been marked as a duplicate of this bug. ***
Comment 7 Chris Wilson 2010-12-22 12:50:30 UTC
In airlied/drm-fixes:

commit 92971021c632876108ea2e06290a56a9157578f5
Author: Dave Airlie <airlied@redhat.com>
Date:   Tue Dec 21 12:47:56 2010 +1000

    Revert "drm: Don't try and disable an encoder that was never enabled"
    
    This reverts commit 541cc966915b6756e54c20eebe60ae957afdb537.
    
    Wei Yonjun reported this caused a regression against Intel VGA hotplug
    on his G33 hw.
    
    Signed-off-by: Dave Airlie <airlied@redhat.com>

just waiting for Linus to pull.
Comment 8 Rafael J. Wysocki 2010-12-29 22:52:42 UTC
Fixed by commit 9297102 Revert "drm: Don't try and disable an encoder that was never enabled" .
Comment 9 Oliver Herold 2011-01-10 10:42:17 UTC
The problem isn't solved: https://bugzilla.kernel.org/show_bug.cgi?id=22872

Note You need to log in before you can comment on or make changes to this bug.