Bug 24802 - Graphics errors with Radeon KMS driver on RV770
Summary: Graphics errors with Radeon KMS driver on RV770
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-13 00:54 UTC by Reiner Herrmann
Modified: 2011-03-07 18:43 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.36.2
Tree: Mainline
Regression: Yes


Attachments

Description Reiner Herrmann 2010-12-13 00:54:59 UTC
After upgrading from 2.6.36.1 to 2.6.36.2 there are some graphics errors (looks texture related) in OpenGL applications (e.g. OpenArena, foobillard).
It is working normally (without those errors) when switching back to 2.6.36.1.
Comment 1 Alex Deucher 2010-12-13 01:03:12 UTC
Can you bisect what commit is problematic?
Comment 2 Reiner Herrmann 2010-12-13 14:23:34 UTC
I just bisected it and found the problematic commit:

3645e7665f285b51fbb5aa73a255b858abe72cfc is the first bad commit
commit 3645e7665f285b51fbb5aa73a255b858abe72cfc
Author: Alex Deucher <alexdeucher@gmail.com>
Date:   Mon Oct 18 23:54:56 2010 -0400

    drm/radeon/kms: properly compute group_size on 6xx/7xx
    
    commit 881fe6c1d06bf49f4ab7aef212cdaf66bd059614 upstream.
    
    Needed for tiled surfaces.
    
    Signed-off-by: Alex Deucher <alexdeucher@gmail.com>
    Signed-off-by: Dave Airlie <airlied@redhat.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

:040000 040000 996abb61f4c4ccd436f84f159fd50237fb542ed1 b31fe649b2eaff0ed1b7abf05898a75dbbb81dfa M      drivers


When reversing this commit in 2.6.36.2, everything is running normally again.
Comment 3 Alex Deucher 2010-12-13 15:37:41 UTC
This is actually a bug in mesa.  It's fixed by this commit:
http://cgit.freedesktop.org/mesa/mesa/commit/?id=5b15b5f4a8fffa07d8051e6cd4cd0a6c9288fc9f
Comment 4 Alex Deucher 2010-12-13 15:48:01 UTC
Unfortunately, there's no way to support both old and new mesa at the same time properly because the group size calculation happens when the GPU is initialized prior to any userspace libs loading.  You can't reconfigure the memory controller per client and setting the group size wrong means you won't be able to use new features like 2D tiling.
Comment 5 Robert Hooker 2011-01-20 20:45:59 UTC
This has been applied to 2.6.35 longterm, is it appropriate there given that it breaks userspace? Ubuntu started getting a large amount of bug reports about things being broken after updating to 2.6.35.10.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/703553
Comment 6 Jérôme Glisse 2011-03-07 18:43:54 UTC
Solution is to update mesa, see comment #4 for why it can't be fixed properly otherwise, closing this bug

Note You need to log in before you can comment on or make changes to this bug.