Bug 2478 - system noise when using ACPI -- HP nx7000
Summary: system noise when using ACPI -- HP nx7000
Status: REJECTED DUPLICATE of bug 3406
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Processor (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Zhu Yi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-08 15:06 UTC by Steffen Hein
Modified: 2004-11-16 23:08 UTC (History)
3 users (show)

See Also:
Kernel Version: Kernel 2.6 series (still exists in 2.6.5)
Tree: Mainline
Regression: ---


Attachments

Description Steffen Hein 2004-04-08 15:06:23 UTC
Distribution: Debian Sarge 
Hardware Environment: HP nx7000 notebook (Centrino-based), US model is called 
"x1000" 
Software Environment: Custom kernels compiled from vanilla sources (no 
patches) 
 
Problem Description: 
When using the acpi processor module, the notebook makes a very high-pitched 
sound. The problem seems to occur on all notebooks of that series, not only my 
own one. Couldn't check other centrino/pentium-m based notebooks. 
The sound stops as soon as frequency scaling is being used. 
 
This may, of course, be connected to some hardware-specialities. But the 
reason for this bug-report is: 
- The noise doesn't occur under "that other OS"[tm] 
- The noise really doesn't sound very healthy 
 
Maybe one of the kernel developers has such a notebook (seems to be a very 
popular model) and can help to investigate on this issue. 
 
Steps to reproduce: 
Use a 2.6 kernel with acpi processor support enabled and boot it on a 
nx7000/x1000 machine. 
 
Some log messages: 
Apr  6 20:26:12 nx7000 kernel: Initializing CPU#0 
Apr  6 20:26:12 nx7000 kernel: Detected 1495.175 MHz processor. 
Apr  6 20:26:12 nx7000 kernel: Console: colour VGA+ 80x25 
Apr  6 20:26:12 nx7000 kernel: Calibrating delay loop... 2981.88 BogoMIPS 
Apr  6 20:26:12 nx7000 kernel: Memory: 512552k/524096k available (1783k kernel 
code, 11156k reserved, 549k data, 280k init, 0k highmem) 
Apr  6 20:26:12 nx7000 kernel: Dentry-cache hash table entries: 65536 (order: 
7, 524288 bytes) 
Apr  6 20:26:12 nx7000 kernel: Inode-cache hash table entries: 32768 (order: 
6, 262144 bytes) 
Apr  6 20:26:12 nx7000 kernel: Mount-cache hash table entries: 8192 (order: 4, 
65536 bytes) 
Apr  6 20:26:12 nx7000 kernel: Buffer-cache hash table entries: 32768 (order: 
5, 131072 bytes) 
Apr  6 20:26:12 nx7000 kernel: Page-cache hash table entries: 131072 (order: 
7, 524288 bytes) 
Apr  6 20:26:12 nx7000 kernel: CPU: L2 cache: 8192K 
Apr  6 20:26:12 nx7000 kernel: CPU: L3 cache: 5632K 
Apr  6 20:26:12 nx7000 kernel: Intel machine check architecture supported. 
Apr  6 20:26:12 nx7000 kernel: Intel machine check reporting enabled on CPU#0. 
Apr  6 20:26:12 nx7000 kernel: CPU: Intel(R) Pentium(R) M processor 1500MHz 
stepping 05 
Apr  6 20:26:12 nx7000 kernel: Enabling fast FPU save and restore... done. 
Apr  6 20:26:12 nx7000 kernel: Enabling unmasked SIMD FPU exception support... 
done. 
Apr  6 20:26:12 nx7000 kernel: Checking 'hlt' instruction... OK. 
Apr  6 20:26:12 nx7000 kernel: Checking for popad bug... OK. 
Apr  6 20:26:12 nx7000 kernel: POSIX conformance testing by UNIFIX 
Apr  6 20:26:12 nx7000 kernel: enabled ExtINT on CPU#0 
Apr  6 20:26:12 nx7000 kernel: ESR value before enabling vector: 00000000 
Apr  6 20:26:12 nx7000 kernel: ESR value after enabling vector: 00000000 
Apr  6 20:26:12 nx7000 kernel: Using local APIC timer interrupts. 
Apr  6 20:26:12 nx7000 kernel: calibrating APIC timer ... 
Apr  6 20:26:12 nx7000 kernel: ..... CPU clock speed is 1495.2057 MHz. 
Apr  6 20:26:12 nx7000 kernel: ..... host bus clock speed is 99.6803 MHz. 
Apr  6 20:26:12 nx7000 kernel: cpu: 0, clocks: 996803, slice: 498401 
Apr  6 20:26:12 nx7000 kernel: 
CPU0<T0:996800,T1:498384,D:15,S:498401,C:996803> 
Apr  6 20:26:12 nx7000 kernel: mtrr: v1.40 (20010327) Richard Gooch 
(rgooch@atnf.csiro.au) 
Apr  6 20:26:12 nx7000 kernel: mtrr: detected mtrr type: Intel 
Apr  6 20:26:12 nx7000 kernel: PCI: PCI BIOS revision 2.10 entry at 0xf031f, 
last bus=3 
Apr  6 20:26:12 nx7000 kernel: PCI: Using configuration type 1 
Apr  6 20:26:12 nx7000 kernel: PCI: Probing PCI hardware 
Apr  6 20:26:12 nx7000 kernel: PCI: Using IRQ router default [8086/24cc] at 
00:1f.0
Comment 1 Zhu Yi 2004-05-31 02:51:54 UTC
Do you know whether the sound is from the CPU fan?
Does it also happen on recent 2.6.6 (2.6.7-rc2) kernel?
Does it happen if you stop Intel SpeedStep software in "the other OS"?
Comment 2 David Lowe 2004-05-31 04:43:17 UTC
I can confirm a high pitched noise using the 2.6.6-1.397 Arjan kernel under ACPI
using a Dell Inspiron 4150 with a Pentium 4 Mobile 1.6 GHz.

This is not coming from the fan, rather the noise seems identical to the APM
idle noise. According to the kernel mailing lists, this is produced by the new
1kHz clock speed of the 2.6 kernel. If I boot using apm=on
apm=idle-threshold=100 the noise disappears. I have checked this makes no
difference to power consumption and thermal properties of my system. Likewise
the noise was not present under the 2.4 kernels.

I don't know how to turn the noise off under ACPI.
Comment 3 Steffen Hein 2004-06-03 14:13:19 UTC
> Do you know whether the sound is from the CPU fan? 
It's *definitely* not the CPU fan. 
It sounds a bit like the high-pitched tone, some old TVs and CRTs make. 
 
> Does it also happen on recent 2.6.6 (2.6.7-rc2) kernel? 
I'm now using a 2.6.6 kernel but with the C3 powerstate disabled because the 
centrino wlan driver doesn't like it (using the small patch from 
ipw2100.sf.net). No noise with that configuration! 
 
I'll try a vanilla 2.6.7 kernel when it's released. 
 
> Does it happen if you stop Intel SpeedStep software in "the other OS"? 
No 
Comment 4 Zhu Yi 2004-06-17 19:11:56 UTC
2.6.7 was released. How is it going?
Comment 5 Steffen Hein 2004-06-19 08:56:10 UTC
Still happens on a vanilla 2.6.7 kernel. 
Comment 6 Zhu Yi 2004-07-18 22:45:21 UTC
Does set HZ to 100 help?

--- linux-2.6.7/include/asm-i386/param.h	2004-06-17 09:34:28.000000000 
+0800
+++ linux-2.6.7-new/include/asm-i386/param.h	2004-07-19 13:30:54.207125536 
+0800
@@ -2,7 +2,7 @@
 #define _ASMi386_PARAM_H
 
 #ifdef __KERNEL__
-# define HZ		1000		/* Internal kernel timer frequency */
+# define HZ		100		/* Internal kernel timer frequency */
 # define USER_HZ	100		/* .. some user interfaces are 
in "ticks" */
 # define CLOCKS_PER_SEC		(USER_HZ)	/* like times() */
 #endif
Comment 7 Steffen Hein 2004-07-19 04:56:20 UTC
This seems to help. The noise disappeared. 
 
David Lowe: Can you confirm this? 
Comment 8 David Lowe 2004-07-25 03:51:41 UTC
I am no longer able to get my machine to make the same noise under ACPI.
I recall previously my machine loaded the "thermal" and "processor" kernel
modules. However after an update (I'm now using Fedora Core 2), these modules
are no longer there, and seem to have been replaced by asus_acpi, for me.

There is still a faint continuous high-pitched whine, but it is also present
under Windows XP, so I assume its something different, and regard this as a fix.

Under APM the noise is still there, turning on and off dependent on processor
load, so I am still using the apm=idle-threshold=100 boot parameter.


Comment 9 Burcin Erocal 2004-09-07 10:44:30 UTC
I also get the same noise on an HP nx7000 1500MHz Centrino, it is still there
with 2.6.8.1.

The noise seems to be connected to the cpu frequency and system load. If the
load is high, and the cpu is working at a high frequency, the noise stops, when
the load gets low again, the noise comes back. Under low system load, lowering
the cpu speed with cpufreq also stops the noise.

Setting HZ to 100 as in comment 6 solves the problem altogether.

Comment 10 Len Brown 2004-11-16 23:08:29 UTC
note: FC2 includes the processor module as part of the kernel,
which is why you can't unload it.

Others have reported noise when their 2.6 system enters C3
power saving state in idle.  It is good to know that
HZ=100 also addresses the issue.

You can observe C3 usage in /proc/acpi/processor/CPU0/power
You can prevent C3 usage by plugging in a USB mouse,
as this causes bus master activity that prevents entering C3.

You could also run a low priority "cycle soaker" to make
your system never enter idle, and see if that makes the noise
go away.

There are also a couple of ways to disable just C3 in the latest
kernel -- see bug 3549.

closing as a duplicate of 3406 "c3 causes noise".
Please re-open if disabling C3 doesn't fix it.


*** This bug has been marked as a duplicate of 3406 ***

Note You need to log in before you can comment on or make changes to this bug.