Bug 24762 - BUG at perf_ctx_adjust_freq (kernel/perf_event.c:1582)
BUG at perf_ctx_adjust_freq (kernel/perf_event.c:1582)
Status: RESOLVED OBSOLETE
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-12-12 14:49 UTC by Maciej Rutecki
Modified: 2012-07-02 13:50 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.37-rc4
Tree: Mainline
Regression: Yes


Attachments
screenshot from iLO (55.60 KB, image/png)
2011-03-23 14:24 UTC, Jacek Luczak
Details
Another crash screenshot (44.80 KB, image/png)
2011-03-24 12:36 UTC, Jacek Luczak
Details

Description Maciej Rutecki 2010-12-12 14:49:49 UTC
Subject    : BUG at perf_ctx_adjust_freq (kernel/perf_event.c:1582)
Submitter  : Chris Wilson <chris@chris-wilson.co.uk>
Date       : 2010-12-10 12:00
Message-ID : c6d829$pqibha@fmsmga001.fm.intel.com
References : http://marc.info/?l=linux-kernel&m=129198247531612&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2011-02-20 12:46:39 UTC
I'm closing this as unreproducible for now. If it happens again, please shout.
Comment 2 Jacek Luczak 2011-03-23 14:21:12 UTC
Got same issue with plain 2.6.37. Can't really reproduce it as hunted this down for the first time but I suspect that same have happened a day before on two different hosts. Both are under huge load so this might be a key. Got a screenshot from iLO a bit mixed with top output.
Comment 3 Jacek Luczak 2011-03-23 14:24:52 UTC
Created attachment 51742 [details]
screenshot from iLO

Got the screenshot from iLO.
Comment 4 Jacek Luczak 2011-03-24 07:30:50 UTC
Another two hosts running vanilla 2.6.37 died in the night due to same issue. Please reopen.
Comment 5 Jacek Luczak 2011-03-24 09:03:34 UTC
And another one. top was running and the last thing it ,,recorded'' was:

top - 09:52:52 up 17:39, 14 users,  load average: 3.25, 2.45, 2.70
Tasks: 472 total,   9 running, 458 sleeping,   1 stopped,   4 zombie
Cpu(s): 58.8%us,  6.1%sy,  5.1%ni, 29.2%id,  0.6%wa,  0.0%hi,  0.1%si,  0.0%st
Mem:  49553716k total, 49115852k used,   437864k free,   279460k buffers
Swap:  4095996k total,        0k used,  4095996k free, 39703932k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
23840 userr     20   0  706m 107m 9128 S 200.7  0.2   0:08.15 java
23544 userr     20   0  276m  16m 5328 S 140.7  0.0   0:05.63 wmp
Comment 6 Jacek Luczak 2011-03-24 12:36:27 UTC
Created attachment 51882 [details]
Another crash screenshot

Clean screenshot from last crash.
Comment 7 Florian Mickler 2011-04-17 16:18:35 UTC
Is this still an issue in 2.6.38?
Comment 8 Jacek Luczak 2011-04-19 09:09:28 UTC
Did not tested that on 2.6.38. Might be hard as this is triggered by production CI system. For sure I can confirm the problem is in huge number of processes running which cause a load above 100.

Note You need to log in before you can comment on or make changes to this bug.