Bug 24602 - modprobe bttv crashes system
modprobe bttv crashes system
Status: CLOSED CODE_FIX
Product: v4l-dvb
Classification: Unclassified
Component: bt8xx
All Linux
: P1 normal
Assigned To: bt8xx
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-12-09 21:48 UTC by Sergej Pupykin
Modified: 2010-12-27 10:19 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37-rc5
Tree: Mainline
Regression: Yes


Attachments
dmesg output (60.95 KB, text/plain)
2010-12-09 21:48 UTC, Sergej Pupykin
Details

Description Sergej Pupykin 2010-12-09 21:48:21 UTC
Created attachment 39652 [details]
dmesg output

After boot kernel 2.6.37-rc5 I do:
# modprobe tvaudio
# modprobe tuner
# modprobe bttv
crashes here (dmesg output attached), usually system hangs.

2.6.36 works well.

modprobe.conf:
options bttv            card=42 i2c_udelay=128
options tuner           pal=d
alias snd-card-0 snd-bt87x
alias sound-slot-0 snd-bt87x
Comment 1 Florian Mickler 2010-12-17 01:03:40 UTC
Maybe duplicate of #24142.

References: https://bugzilla.kernel.org/show_bug.cgi?id=24142
Comment 2 Mauro Carvalho Chehab 2010-12-17 20:39:28 UTC
This patch likely fixes it:
   https://patchwork.kernel.org/patch/414671/
Comment 3 Sergej Pupykin 2010-12-17 21:52:20 UTC
works for me too.
Comment 4 Florian Mickler 2010-12-18 01:15:41 UTC
Patch: https://patchwork.kernel.org/patch/414671/
Comment 5 Florian Mickler 2010-12-27 10:19:36 UTC
Gitweb:     http://git.kernel.org/linus/587f0d5d6d44e3529028bf197d424f866fb2411d
Commit:     587f0d5d6d44e3529028bf197d424f866fb2411d
Parent:     a757ee2216211278680dd8ac869aabe7b4a9970d
Author:     Mauro Carvalho Chehab <mchehab@infradead.org>
AuthorDate: Wed Dec 15 18:45:42 2010 -0300
Committer:  Mauro Carvalho Chehab <mchehab@redhat.com>
CommitDate: Fri Dec 17 18:39:43 2010 -0200

    [media] bttv: fix mutex use before init (BZ#24602)

Note You need to log in before you can comment on or make changes to this bug.