Bug 24292 - kernel panic while using airmon-ng and iwl3945
kernel panic while using airmon-ng and iwl3945
Status: CLOSED DUPLICATE of bug 24102
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 high
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-12-03 17:42 UTC by filippo
Modified: 2010-12-10 18:49 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.36
Tree: Mainline
Regression: Yes


Attachments
03122010253.jpg (768.68 KB, image/jpeg)
2010-12-03 18:57 UTC, John W. Linville
Details

Description filippo 2010-12-03 17:42:20 UTC
as soon as airmon-ng tries to put my
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
in passive mode, i get a kernel panic.

A screen shot taken with my phone is attacched
Comment 1 filippo 2010-12-03 17:44:45 UTC
sorry, couldn't upload the picture. You can find it here
http://rapidshare.com/files/434694453/03122010253.jpg
Comment 2 John W. Linville 2010-12-03 18:57:56 UTC
Created attachment 38972 [details]
03122010253.jpg
Comment 3 John W. Linville 2010-12-03 18:58:22 UTC
What kernel are you running?
Comment 4 filippo 2010-12-03 22:24:44 UTC
2.6.36. Should i update it?
Comment 5 John W. Linville 2010-12-06 19:53:58 UTC
config NETWORK_PHY_TIMESTAMPING
        bool "Timestamping in PHY devices"
        depends on EXPERIMENTAL
        help
          This allows timestamping of network packets by PHYs with
          hardware timestamping capabilities. This option adds some
          overhead in the transmit and receive paths.

          If you are unsure how to answer this question, answer N.

In the shortrun, you might try turning that off in your .config.

Wey-yi, it looks like iwl3945 isn't leaving enough headroom in the skb for the skb_push in skb_defer_rx_timestamp?
Comment 6 wey-yi.w.guy 2010-12-06 21:38:40 UTC
netdev patch 

http://thread.gmane.org/gmane.linux.network/179850/

Wey
Comment 7 Richard Cochran 2010-12-10 14:26:19 UTC
The following three bugs are all duplicates of each other:                      
                                                                                
  24102                                                                         
  24292                                                                         
  24452                                                                         
                                                                                
They all have the same root cause, and all are fixed by the patch               
posted by Eric Dumazet on netdev:                                               
                                                                                
   http://article.gmane.org/gmane.linux.network/180108                          
                                                                                
The work-around is to disable CONFIG_NETWORK_PHY_TIMESTAMPING.                  
                                                                                
Richard
Comment 8 John W. Linville 2010-12-10 14:28:01 UTC

*** This bug has been marked as a duplicate of bug 24102 ***

Note You need to log in before you can comment on or make changes to this bug.