Bug 24242 - gspca_zc3xx driver produces dark video form webcam.
Summary: gspca_zc3xx driver produces dark video form webcam.
Status: RESOLVED CODE_FIX
Alias: None
Product: v4l-dvb
Classification: Unclassified
Component: webcam (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: webcam
URL:
Keywords:
: 28222 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-02 22:30 UTC by Alexander Kaltsas
Modified: 2012-08-14 13:55 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.36.1
Tree: Mainline
Regression: Yes


Attachments
Adiitional info. proc, lspci, lsusb e.t.c. (59.99 KB, text/plain)
2010-12-02 22:34 UTC, Alexander Kaltsas
Details

Description Alexander Kaltsas 2010-12-02 22:30:56 UTC
The gspca_zc3xx driver in kernel 2.6.36.1 produces a dark video output from the webcam.

It used to have a very clean and sharp image until now.

And because an image equals to a thousand words:

http://imgur.com/Jie1R.png
http://img337.imageshack.us/img337/3042/zc3xx.png

The webcam I use is:

ID 046d:08af Logitech, Inc. QuickCam Easy/Cool

dmesg:

usb 8-1: new full speed USB device using ohci_hcd and address 4
gspca: probing 046d:08af
zc3xx: probe 2wr ov vga 0x0000
zc3xx: probe sensor -> 0011
zc3xx: Find Sensor HV7131R
input: zc3xx as /devices/pci0000:00/0000:00:1e.0/0000:02:01.1/usb8/8-1/input/input8
gspca: video0 created
Comment 1 Alexander Kaltsas 2010-12-02 22:34:20 UTC
Created attachment 38912 [details]
Adiitional info. proc, lspci, lsusb e.t.c.

Additional info:

##############################
## ver_linux script output: ##
##############################

If some fields are empty or look unusual you may have an old version.
Compare to the current minimal requirements in Documentation/Changes.
 
Linux sapiokouti 2.6.36-ARCH #1 SMP PREEMPT Wed Nov 24 06:44:11 UTC 2010 i686 Intel(R) Pentium(R) 4 CPU 2.66GHz GenuineIntel GNU/Linux
 
Gnu C                  4.5.1
Gnu make               3.81
binutils               2.20.1.20100521
util-linux             2.18
mount                  support
module-init-tools      3.12
e2fsprogs              1.41.12
jfsutils               1.1.14
reiserfsprogs          3.6.21
xfsprogs               3.1.3
pcmciautils            017
PPP                    2.4.5
Linux C Library        2.12.1
Dynamic linker (ldd)   2.12.1
Linux C++ Library      6.0.14
Procps                 3.2.8
Net-tools              1.60
Kbd                    1.15.2
Sh-utils               8.7
wireless-tools         29
Modules Loaded         gspca_zc3xx gspca_main videodev v4l1_compat nls_cp437 omfs jfs xfs exportfs hfs hfsplus vfat fat isofs udf usb_storage hidp rfcomm sco bnep l2cap ipv6 lm85 hwmon_vid ext2 ext4 jbd2 crc16 ext3 jbd mbcache nvidia joydev btusb bluetooth hid_sunplus loop lirc_igorplugusb lirc_dev ftdi_sio usbhid hid b43 led_class snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq usbserial snd_emu10k1 snd_pcm_oss fuse snd_mixer_oss snd_rawmidi ssb snd_seq_device snd_util_mem snd_hwdep snd_intel8x0 ohci_hcd mmc_core uhci_hcd mac80211 firewire_ohci snd_ac97_codec pcmcia ehci_hcd parport_pc ac97_bus emu10k1_gp firewire_core ne2k_pci pcmcia_core crc_itu_t 8390 ppdev gameport snd_pcm usbcore intel_agp iTCO_wdt iTCO_vendor_support snd_timer thermal cfg80211 shpchp button processor i2c_i801 pci_hotplug agpgart snd i2c_core lp rfkill soundcore parport snd_page_alloc psmouse evdev pcspkr serio_raw sg aes_i586 aes_generic arc4 ecb reiserfs dm_mod sd_mod sr_mod cdrom pata_acpi ata_piix libata floppy scsi_mod
Comment 2 Alexander Kaltsas 2010-12-03 20:00:42 UTC
The commit that creates the problem is commit 
2af0b4c60cc0daf0a3abbaa159380fd729dcf729.

----------------------- GIT bisect -----------------------------------------------

2af0b4c60cc0daf0a3abbaa159380fd729dcf729 is the first bad commit
commit 2af0b4c60cc0daf0a3abbaa159380fd729dcf729
Author: Jean-François Moine <moinejf@free.fr>
Date:   Wed Aug 4 07:12:57 2010 -0300

    V4L/DVB: gspca - zc3xx: Add the light frequency control for sensor hv7131r

    The new exchanges are extracted from the public file lPEPI264v.inf of the
    ms-Windows driver. In this file, the sensor is named hv7131b but the exchanges
    are those of the hv7131r.

    Signed-off-by: Jean-François Moine <moinejf@free.fr>
    Signed-off-by: Mauro Carvalho Chehab <mchehab@redhat.com>

:040000 040000 97b648701eb35eb594f5023351b0ac4cd1067da3 2b18e38beb6fc32c772168738b8479f81fdaee71 M      drivers

----------------------------------------------------------------------------------

Without this commit the webcam works fine.
Comment 3 Vujaklija Damir 2010-12-06 22:18:07 UTC
i have the same problem.

my webcam is : ID 046d:08da Logitech, Inc. QuickCam Messanger

dmesg :
usb 2-4: new full speed USB device using ohci_hcd and address 4
gspca: probing 046d:08da
zc3xx: probe 2wr ov vga 0x0000
zc3xx: probe sensor -> 0011
zc3xx: Find Sensor HV7131R
input: zc3xx as /devices/pci0000:00/0000:00:02.0/usb2/2-4/input/input6
gspca: video0 created
Comment 4 Alexander Kaltsas 2010-12-14 15:40:19 UTC
Does anyone deals with this issue?
Comment 5 Sergey Manucharian 2011-01-11 00:10:05 UTC
I've played a little with the latest driver at

http://moinejf.free.fr/gspca-2.11.20.tar.gz

and the old one from 2.6.35.9 kernel.

If I use parameters "from the public file lPEPI264v.inf" in the old driver it behaves as the new one (providing a non-contrast picture) only if I add and refer the structures:

hv7131r_NoFliker, hv7131r_NoFlikerScale,
hv7131r_50HZ, hv7131r_50HZScale,
hv7131r_60HZ, hv7131r_60HZScale

like the new driver does. But removing references to:

hv7131r_NoFliker, hv7131r_NoFlikerScale

makes it to work almost as before with crisp picture, although it takes more time to accommodate the illumination. However, removing those references from the latest driver does not help.

This was just a brief experiment and may give a hint to the developers.
Comment 6 Thomas Ingerslev 2011-02-19 21:56:18 UTC
This driver problem still exists in the lastet kernel 2.6.38-rc5.

Has anyone been assigned to this bug yet?
Comment 7 Sergey Manucharian 2011-02-20 06:32:32 UTC
It is already fixed by Jean-François Moine ( http://moinejf.free.fr ) a month ago, you can use the current driver (gspca-2.12.14.tar.gz) form his web site.
Comment 8 Jean-Francois Moine 2011-05-16 10:26:19 UTC
*** Bug 28222 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.