Bug 24042 - Massive interrupt rate from WiFi Card (rtl8187se) after suspend
Massive interrupt rate from WiFi Card (rtl8187se) after suspend
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Staging
i386 Linux
: P1 high
Assigned To: drivers_staging@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-11-29 20:37 UTC by Filipp Andjelo
Modified: 2013-12-10 22:43 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.36
Tree: Mainline
Regression: Yes


Attachments

Description Filipp Andjelo 2010-11-29 20:37:19 UTC
I noticed pure performance of my notebook, Belinea o.book 13014, after suspend to ram. I was searching for the cause, everything seemed to be ok, low CPU load, a lot of free memory, but then I've started powertop, in the hope to see a little bit more, and here you are, the WiFi Network Device is interrupting rapidly, thousands of times per second.
The WiFi device is a Realtek RTL8187SE, unloading the drivers doesn't help. In addition I tested kernel 2.6.32 and there is no such problem there. Please tell me which additional information I could contribute to help to fix the problem.
Comment 1 Rafael J. Wysocki 2010-11-29 21:42:45 UTC
This seems to be a driver problem (which is a staging one, so not 100%
supported).

It would be good to identify the first failing kernel at least.
Comment 2 Filipp Andjelo 2010-12-04 18:20:34 UTC
Kernel 2.6.35.9 seems not to have this bahavior. So it came probably with the 2.6.31 first. This problem becomes anoying, since suspend is kind of important feature for notebook users. Shouldn't we set its importance level to high?
Comment 3 Filipp Andjelo 2010-12-17 22:29:50 UTC
Since the problem ocured I've noticed some kind of WiFi signal instability. Sometimes I get 5% signal strength and have to reconnect to the accesspoint. After that I can work again. This is something I can live with, but the suspend problem makes the notebook unusable.  Please tell me how I can help.
Comment 4 Rafael J. Wysocki 2011-01-16 22:44:13 UTC
Is the problem still present in 2.6.37?
Comment 5 Filipp Andjelo 2011-01-19 23:13:49 UTC
I found a time to test it with 2.6.37 and I have to say that the problem still remains. I'm very frustrated about this issue, since I updated to 2.6.36 I can not use my notebook. Turn it every time off is not an option :(
I think, I'll fallback to 2.6.35 again, there were some problem too, but I can live with that kind.
Comment 6 David Regev 2011-04-15 15:24:30 UTC
This bug’s status is that info is needed. So, what can I do to help?

Fillipp: I feel your frustration as well. What’s frustrating even more is that resuming from suspend used to work (with the kernel that came with Ubuntu 10.04) and then suddenly stopped. I’ve almost gotten “used to” the idea that I need to turn off the wireless card when resuming, and that I must reboot if I want to reconnect.

Note You need to log in before you can comment on or make changes to this bug.