Bug 23902 - [BUG] 2.6.37-rc3 massive interactivity regression on ARM
[BUG] 2.6.37-rc3 massive interactivity regression on ARM
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: ARM
All Linux
: P1 normal
Assigned To: linux-arm-kernel@lists.arm.linux.org.uk
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-28 15:07 UTC by Maciej Rutecki
Modified: 2010-12-30 18:29 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.37-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-11-28 15:07:11 UTC
Subject    : [BUG] 2.6.37-rc3 massive interactivity regression on ARM
Submitter  : Mikael Pettersson <mikpe@it.uu.se>
Date       : 2010-11-27 15:16
Message-ID : 19697.8378.717761.236202@pilspetsen.it.uu.se
References : http://marc.info/?l=linux-kernel&m=129087098911837&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-12-06 22:27:14 UTC
On Saturday, December 04, 2010, Mikael Pettersson wrote:
> Mikael Pettersson writes:
>  > Rafael J. Wysocki wrote:
>  > > This message has been generated automatically as a part of a summary report
>  > > of recent regressions.
>  > > 
>  > > The following bug entry is on the current list of known regressions
>  > > from 2.6.36.  Please verify if it still should be listed and let the tracking team
>  > > know (either way).
>  > > 
>  > > 
>  > > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=23902
>  > > Subject		: [BUG] 2.6.37-rc3 massive interactivity regression on ARM
>  > > Submitter	: Mikael Pettersson <mikpe@it.uu.se>
>  > > Date		: 2010-11-27 15:16 (6 days old)
>  > > Message-ID	: <19697.8378.717761.236202@pilspetsen.it.uu.se>
>  > > References	: http://marc.info/?l=linux-kernel&m=129087098911837&w=2
>  > 
>  > The bug is still present in 2.6.37-rc4.  I'm currently trying to bisect it.
> 
> git bisect identified
> 
> [305e6835e05513406fa12820e40e4a8ecb63743c] sched: Do not account irq time to current task
> 
> as the cause of this regression.  Reverting it from 2.6.37-rc4 (requires some
> hackery due to subsequent changes in the same area) restores sane behaviour.
> 
> (Author of original patch cc:d.)
> 
> The original patch submission talks about irq-heavy scenarios.  My case is the
> exact opposite: UP, !PREEMPT, NO_HZ, very low irq rate, essentially 100% CPU
> bound in userspace but expected to schedule quickly when needed (e.g. running
> top or ps or just hitting CR in one shell while another runs a compile job).
Comment 2 Rafael J. Wysocki 2010-12-06 22:29:06 UTC
First-Bad-Commit : 305e6835e05513406fa12820e40e4a8ecb63743c
Comment 3 Rafael J. Wysocki 2010-12-19 13:41:32 UTC
On Sunday, December 19, 2010, Mikael Pettersson wrote:
> Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions
> > from 2.6.36.  Please verify if it still should be listed and let the tracking team
> > know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=23902
> > Subject		: [BUG] 2.6.37-rc3 massive interactivity regression on ARM
> > Submitter	: Mikael Pettersson <mikpe@it.uu.se>
> > Date		: 2010-11-27 15:16 (23 days old)
> 
> The regression is still present in 2.6.37-rc6.
Comment 4 Mikael Pettersson 2010-12-27 14:08:56 UTC
Fixed in 2.6.37-rc7, presumably by 8e92c20183ed0579d94501311b81c42b65cb2129 and/or fe44d62122829959e960bc699318d58966922a69.
Comment 5 Rafael J. Wysocki 2010-12-30 14:46:54 UTC
On Thursday, December 30, 2010, Mikael Pettersson wrote:
> Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions
> > from 2.6.36.  Please verify if it still should be listed and let the tracking team
> > know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=23902
> > Subject		: [BUG] 2.6.37-rc3 massive interactivity regression on ARM
> > Submitter	: Mikael Pettersson <mikpe@it.uu.se>
> > Date		: 2010-11-27 15:16 (33 days old)
> 
> Fixed in 2.6.37-rc7.

Note You need to log in before you can comment on or make changes to this bug.