Bug 23882 - [Regression, post-2.6.37-rc2] Unable to start KDE with 2.6.37-rc3 on Acer Ferrari One
[Regression, post-2.6.37-rc2] Unable to start KDE with 2.6.37-rc3 on Acer Fer...
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-28 13:24 UTC by Maciej Rutecki
Modified: 2010-11-30 10:42 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-11-28 13:24:08 UTC
Subject    : [Regression, post-2.6.37-rc2] Unable to start KDE with 2.6.37-rc3 on Acer Ferrari One
Submitter  : "Rafael J. Wysocki" <rjw@sisk.pl>
Date       : 2010-11-24 0:22
Message-ID : 201011240122.33174.rjw@sisk.pl
References : http://marc.info/?l=linux-kernel&m=129055824500437&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 16790569eddf4d406a16a65f4750f405fa669c52
Author: Alex Deucher <alexdeucher@gmail.com>
Date:   Sun Nov 14 20:24:35 2010 -0500

    drm/radeon/kms: fix and unify tiled buffer alignment checking for r6xx/7xx

First-Bad-Commit : 16790569eddf4d406a16a65f4750f405fa669c52
Comment 1 Alex Deucher 2010-11-29 14:42:10 UTC
Patch here:
http://lists.freedesktop.org/archives/dri-devel/2010-November/005826.html
as dicsussed here:
http://lists.freedesktop.org/archives/dri-devel/2010-November/005821.html

Should show up in the next drm fix merge.
Comment 2 Florian Mickler 2010-11-30 10:42:34 UTC
Fixed in mainline. 

commit fba4312e223f1187efc8c083daed70e57fa9c9d3
Author: Alex Deucher <alexdeucher@gmail.com>
Date:   Sun Nov 14 20:24:35 2010 -0500

    drm/radeon/kms: fix and unify tiled buffer alignment checking for r6xx/7xx

(and commit 16790569eddf4d406a16a65f4750f405fa669c52)

Note You need to log in before you can comment on or make changes to this bug.