Bug 23782 - needinfo is cumbersome
Summary: needinfo is cumbersome
Status: RESOLVED OBSOLETE
Alias: None
Product: Other
Classification: Unclassified
Component: Bug Tracker (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Bug Me Administrator
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-25 22:24 UTC by Felipe Contreras
Modified: 2015-02-19 16:01 UTC (History)
3 users (show)

See Also:
Kernel Version: -
Tree: Mainline
Regression: No


Attachments

Description Felipe Contreras 2010-11-25 22:24:08 UTC
Right now the reporter cannot change the status away from NEEDINFO once the information has been provided.

Ideally needinfo should be a flag, turned of when the information has been provided.
Comment 1 Florian Mickler 2010-12-01 11:15:35 UTC
Also the states "VERIFIED", "REJECTED" and "DEFERRED" are only accessible through NEEDINFO and probably shouldn't be accessible at all. 

I think current practice is to set the state to "CLOSED" and the resolution appropriate, instead of setting the state to VERIFIED, REJECTED or DEFERRED. 

Rafael, do you have any thoughts on this?
Comment 2 Rafael J. Wysocki 2010-12-01 20:34:09 UTC
The fact that the reporter cannot change NEEDINFO into something else is
certainly a bug.

I agree with you that we only need RESOLVED and CLOSED, but that's a different
issue.
Comment 3 Felipe Contreras 2013-12-12 07:36:44 UTC
Is this really obsolete?
Comment 4 Alan 2013-12-12 14:58:23 UTC
I closed it as its against a different bugzilla install to the one we have. You can re-open it, leave it three years and close it again if you like, nothing will happen.

If you want this fixing then it needs to go to the bugzilla maintainer email who don't use bugzilla because the LF has a separate ticketing system for sysadmin type stuff.
Comment 5 Felipe Contreras 2013-12-12 22:21:21 UTC
(In reply to Alan from comment #4)
> I closed it as its against a different bugzilla install to the one we have.
> You can re-open it, leave it three years and close it again if you like,
> nothing will happen.

So basically you are saying this bugzilla is a farce. Nobody cares if the information requested is properly tracked.

> If you want this fixing then it needs to go to the bugzilla maintainer email
> who don't use bugzilla because the LF has a separate ticketing system for
> sysadmin type stuff.

Then why have a "bug tracker" component?
Comment 6 Alan 2013-12-12 23:44:37 UTC
No I'm saying that these days bugzilla is managed by a ticketing system run by the Linux Foundation. It had a long period of basically not being properly managed, but with kernel.org under LF management it is now properly managed, just not via bugzilla itself.

And we still have a bug tracker component as nobody has removed it (it's *very* hard to ever remove a component from most versions of Bugzilla). Perhaps you could also ask the bugzilla maintainer to remove it.

Note You need to log in before you can comment on or make changes to this bug.