Bug 23552 - NFS readdir change break fully cached nfs root
NFS readdir change break fully cached nfs root
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: NFS
All Linux
: P1 normal
Assigned To: Trond Myklebust
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-22 22:40 UTC by Rafael J. Wysocki
Modified: 2010-11-22 22:55 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.37-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-11-22 22:40:51 UTC
Subject    : [regression] NFS readdir change break fully cached nfs root
Submitter  : Andi Kleen <andi@firstfloor.org>
Date       : 2010-11-02 19:00
Message-ID : Message-ID: <20101102180051.GA26089@basil.fritz.box>
References : http://permalink.gmane.org/gmane.linux.nfs/36540
Handled-By : Trond Myklebust <Trond.Myklebust@netapp.com>
Patch      : http://marc.info/?l=linux-kernel&m=128888689009058&w=4

This entry is being used for tracking a regression from 2.6..  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-11-22 22:42:07 UTC
This entry is being used for tracking a regression from 2.6.36.
Comment 2 Trond Myklebust 2010-11-22 22:55:03 UTC
The fix has already been pushed to mainline. Please see
commit 8cd51a0ccd1beda4482507769887c0be9d70f8c1 (NFS: Fix a couple of
regressions in readdir.)
Comment 3 Trond Myklebust 2010-11-22 22:55:37 UTC
Please reopen if the problem reoccurs.

Note You need to log in before you can comment on or make changes to this bug.