Bug 23502 - Dell Inspiron 15n n5030 laptop alps touchpad is detected as a “PS/2 Generic Mouse “
Dell Inspiron 15n n5030 laptop alps touchpad is detected as a “PS/2 Generic M...
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-22 04:42 UTC by John
Modified: 2013-12-10 22:40 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.35, 2.6.36, & 2.6.37
Tree: Mainline
Regression: No


Attachments
System Info (49.88 KB, text/plain)
2010-11-22 04:42 UTC, John
Details

Description John 2010-11-22 04:42:39 UTC
Created attachment 37842 [details]
System Info

The touchpad is partially functional, it moves the cursor around the screen and tapping is seen as a left click and the left and right buttons work but I do not have any horizontally or vertical scrolling. Also since the kernel does not see the touchpad as a touchpad there is no way to adjust any settings for the touchpad. I think the problem is the the /drivers/input/mouse/alps.c script which does not have the information needed for my model of touchpad to be detected as a alps so then it defaults to a “PS/2 Generic Mouse “ 

I have looked over the internet for a bug report for this which I did find but they where for different models. I have listed the bug reports that I have found.
https://bugs.launchpad.net/archlinux/+bug/527890
http://ubuntuforums.org/showthread.php?t=1316361
https://bugzilla.kernel.org/show_bug.cgi?id=13134
http://wiki.ubuntuusers.de/Touchpad#Touchpad-wird-nicht-erkannt

I did try a kernel hack from https://bugs.launchpad.net/ubuntu/+source/linux/+bug/550625/comments/154 but it did not work.

Attached is my system info
Comment 1 John 2011-01-31 11:49:40 UTC
This bug has been reported on Ubuntu's site https://bugs.launchpad.net/ubuntu/+source/linux/+bug/678103

Note You need to log in before you can comment on or make changes to this bug.