Bug 23462 - DVI/EDID broken with Intel i945 graphics and 2.6.37-rc2
DVI/EDID broken with Intel i945 graphics and 2.6.37-rc2
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-21 16:32 UTC by Maciej Rutecki
Modified: 2010-12-03 22:06 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-11-21 16:32:46 UTC
Subject    : DVI/EDID broken with Intel i945 graphics and 2.6.37-rc2
Submitter  : Tino Keitel <tino.keitel@tikei.de>
Date       : 2010-11-16 18:49
Message-ID : 20101116184914.GA15794@mac.home
References : http://marc.info/?l=linux-kernel&m=128993389113001&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Tino Keitel 2010-12-03 06:53:38 UTC
Fixed with 2.6.37-rc4-git2.
Comment 2 Rafael J. Wysocki 2010-12-03 20:29:41 UTC
By which commit?
Comment 3 Tino Keitel 2010-12-03 20:46:15 UTC
I tested "drm/i915/sdvo: Always fallback to querying the shared DDC line" (see LKML) which helped. This commit is merged in 2.6.37-rc4-git2:

commit 0c1dab89ee0e483f382391d6aec77db4affb0931
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Nov 23 22:37:01 2010 +0000

    drm/i915/sdvo: Always fallback to querying the shared DDC line
    
    On a few devices, like the Mac Mini, the CRT DDC pins are shared between
    the analog connector and the digital connector. In this scenario, rely
    on the EDID to determine if a digital panel is connected to the digital
    connector.
    
    Reported-and-tested-by: Tino Keitel <tino.keitel@tikei.de>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>

Note You need to log in before you can comment on or make changes to this bug.