Bug 23382 - Graphical glitches on GM965 since 2.6.37-rc1
Graphical glitches on GM965 since 2.6.37-rc1
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
https://bugs.launchpad.net/ubuntu/+so...
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-20 18:06 UTC by Brian Rogers
Modified: 2010-12-02 21:38 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Brian Rogers 2010-11-20 18:06:28 UTC
Since 2.6.37-rc1, I see graphical glitches on various UI widgets. This can show as any of the following:

- a black rectangle around the URL bar in Firefox
- slightly glitchy scrollbars in various programs (most noticeably Konsole)
- a lot of graphical corruption occasionally covers the document list and toolbar in Kate

None of these effects are always there. They come and go. Overall, KDE applications seem to be more affected, and the problem is only severe with Compiz running. Without Compiz, the glitches are rarer and less obvious. Stability seems unaffected by the glitches, and 3D works without problems or glitches.

This problem doesn't exist with 2.6.36.

Observed on both Ubuntu Maverick and Ubuntu Natty (with xf86-video-intel 2.13.0-1ubuntu1) with a 2.6.37-rc1 kernel. On Natty, I verified that this bug is still present on a mainline kernel with the 2010-11-19 drm-intel-fixes merge.

System info provided by apport is available in the downstream bug I filed.
Comment 1 Florian Mickler 2010-11-30 11:16:43 UTC
You probably forgot to post the link to the mentioned bugreport.
Comment 2 Chris Wilson 2010-11-30 11:19:59 UTC
This is likely fixed by 

commit de18a29e0fa3904894b4e02fae0e712cd43f740c
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Sat Nov 27 22:30:41 2010 +0100

    drm/i915: fix regression due to ba3d8d749b01548b9
    
    We don't track gpu flush request in any special way. So even with
    obj->write_domain == 0, a gpu flush might be outstanding but no
    yet executed. Even worse, the latest request might use the object
    only for reading. So and unconditional call to object_wait_rendering
    is needed for !pipelined.
    
    Hence revert that patch fully and untangle the flushing from the
    synchronization again.
    
    Reported-by: Keith Packard <keithp@keithp.com>
    Tested-by: Keith Packard <keithp@keithp.com>
    Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>

which is working its way upstream, and is currently available from drm-intel-fixes.
Comment 3 Brian Rogers 2010-11-30 15:52:52 UTC
Running a kernel with that, it looks good so far. I'll correct myself if I see a glitch pop up.

The downstream report is here, BTW:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/677770

I have it in the URL field of this bug report, but I guess it isn't very obvious there.
Comment 4 Florian Mickler 2010-11-30 18:59:48 UTC
Ah, indeed you have. I overlooked it. 

Chris, I just wanted to add a link to the patch, but I don't seem to find it on intel-gfx or dri-devel. (I did look only superficial for the subject line and mails from Daniel.) 

Where do patches usually get posted? 


Patch: http://git.kernel.org/?p=linux/kernel/git/ickle/drm-intel.git;a=commit;h=de18a29e0fa3904894b4e02fae0e712cd43f740c
Comment 5 Chris Wilson 2010-11-30 20:06:26 UTC
Usually intel-gfx@. This particular regression was raised and debugged on irc and no patch made its way to the list. Hmm, I think I will try and enforce a cooling off period such that all patches must first be staged and to email all patches pushed to -staging to the list for review.
Comment 6 Florian Mickler 2010-11-30 20:27:10 UTC
I don't know what's the recommended workflow, but for tracking purposes a link to a mailinglist posted patch is more helpful then a link to a git repository. With a mailinglist posted patch, issues have a chance of being reported in that same thread and are then automatically visible from the bugreport. Whereas for patches where google does not find a post, you have very few ways to find issues or discussion about it,...
Comment 7 Rafael J. Wysocki 2010-12-02 20:50:35 UTC
*** Bug 22542 has been marked as a duplicate of this bug. ***
Comment 8 Rafael J. Wysocki 2010-12-02 21:38:49 UTC
Fixed by commit de18a29 drm/i915: fix regression due to ba3d8d749b01548b9 .

Note You need to log in before you can comment on or make changes to this bug.