Bug 2327 - AGPGART SIS crashes on sis648
AGPGART SIS crashes on sis648
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Video(AGP)
i386 Linux
: P2 blocking
Assigned To: Dave Jones
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-18 08:38 UTC by Duarte Santos
Modified: 2004-04-06 02:19 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.4 and 2.6.5rc1-mm1
Tree: Mainline
Regression: ---


Attachments
Patch from some guy in kernel mail list (9.02 KB, patch)
2004-03-19 10:22 UTC, Duarte Santos
Details | Diff
A patch against 2.6.5 to let the SiS 746 also get the special treatment (1.23 KB, patch)
2004-04-05 19:54 UTC, Bjoern Michaelsen
Details | Diff

Description Duarte Santos 2004-03-18 08:38:58 UTC
Distribution:GENTOO 2004.0
Hardware Environment: CLEVO LAPTOP P4 2.8 AGP=SIS648 REST=SIS963 DISK=SIS5513
USB=SIS7001 SOUND=SIS7012 GRAPHIC CARD= RADEON M10 9600 
Software Environment: GENTOO - kernel compiled withou acpi and preemp and other
tweaks.
Problem Description: As soon as the agpgart is called it crashes 

Steps to reproduce: Well just compile the kernel as normal with SIS in AGPGART,
i tried as a module too. I also tried severeal ways to boot the pci with bios
and non bios.
Comment 1 Duarte Santos 2004-03-19 10:22:39 UTC
Created attachment 2369 [details]
Patch from some guy in kernel mail list

It's for kernel 2.6.2 .... it works on 2.6.3 too
Comment 2 Bjoern Michaelsen 2004-03-20 10:18:49 UTC
This problem arises also with the SiS 746 agp bridge with AGP 3.0
The system doesnt crash completely though, it can be recovered via SysRq+k or
ssh. A X is running with 99% CPU-time while the machine is unresponsive.
On the second try X starts.
For details see:
http://bugs.gentoo.org/show_bug.cgi?id=40891
This patch:
http://lkml.org/lkml/2004/2/22/102
by Oliver Schoett solved the problem for me, however it seems to be already
included in the patch posted above.
Oliver Schoett on the lkml:
"It appears that the chips are electrically unstable for ca. 5ms after switching
them to AGP 3.0, and the effects vary depending on what your driver does in that
interval."
Comment 3 Duarte Santos 2004-03-25 07:56:22 UTC
Working patch in 2.6.5-rc2-mm3!! Thanks 
Comment 4 Bjoern Michaelsen 2004-04-05 19:54:12 UTC
Created attachment 2510 [details]
A patch against 2.6.5 to let the SiS 746 also get the special treatment 

The SiS 746 has the same weird problems during initialisation as the SiS 648.
see my statements from 2004-03-20.
The changes in 2.6.5 make to previous ugly hack superfluous, but apply only to
the SiS 648 and not to the SiS 746.
The new patch against 2.6.5 applies the 5ms wait after initializing AGP to the
SiS 746 too.
Comment 5 Dave Jones 2004-04-06 02:19:17 UTC
thanks, that patch (or something similiar) should already be in the latest -mm
tree. There's quite a few pending agp changesets now, so I'll push those along
when Linus gets back.

Note You need to log in before you can comment on or make changes to this bug.