Bug 23202 - efi: need physical mode to boot in EFI mode properly on new macbook airs
efi: need physical mode to boot in EFI mode properly on new macbook airs
Status: RESOLVED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-18 10:58 UTC by Brian Tarricone
Modified: 2012-08-14 13:06 UTC (History)
5 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments
run EFI in physical mode (12.94 KB, patch)
2010-11-18 10:58 UTC, Brian Tarricone
Details | Diff

Description Brian Tarricone 2010-11-18 10:58:22 UTC
Created attachment 37432 [details]
run EFI in physical mode

I'm unable to boot without 'noefi' on the new MacBookAir3,1 model.  I found a patch from Takao Indoh that allows booting in physical mode instead of virtual.  Updated it for 2.6.37-rc2 and gave it a shot, and now everything's working without 'noefi', which fixes some IRQ assignment problems with the USB and SATA controllers.

Not sure if this should be enabled by default; if requested I can rework the patch to default to virtual mode, with a cmdline param for physical.
Comment 1 H. Peter Anvin 2010-11-18 18:34:18 UTC
We have had some serious discussion about always doing physical mode, and this would sort of confirm that physical mode should at least be the default, if not the only mode.
Comment 2 H. Peter Anvin 2010-11-18 18:34:41 UTC
Could you post this patch to LKML for review (and Cc: me, please?)
Comment 3 Brian Tarricone 2010-11-19 00:06:21 UTC
Sure, done.
Comment 4 Alexey Shvetsov 2011-01-12 16:18:05 UTC
This patch also works on intel dp55wg motherboard with intel uefi. Without it it can only boot in uniprocessor mode and noefi kernel cmdline

PS but kernel still hangs on usb initialization
Comment 5 Jérémy Lal 2011-05-08 05:17:46 UTC
That patch does wonders on iMac12,2 27" (latest with sandy bridge), applied on kernel 2.6.38, booted through grub-efi in debian/wheezy

* only kernel option needed is radeon.modeset=0,
  (because of https://bugs.freedesktop.org/show_bug.cgi?id=27314)
* usb, reboot, halt work

thanks !
Comment 6 Jérémy Lal 2011-05-24 06:10:24 UTC
Update : a set of patches from Matthew Garrett fixes virtual mode efi for imac12,2 (and maybe other models) :
http://git.kernel.org/?p=linux/kernel/git/x86/linux-2.6-tip.git;a=shortlog;h=935a638241b0658b9749edd060f972575f9d4a78
and
https://lkml.org/lkml/2011/5/19/377
Comment 7 Jérémy Lal 2012-07-30 16:10:53 UTC
It is fixed on imac12,2 at least since kernel 3.2

Note You need to log in before you can comment on or make changes to this bug.