Bug 23142 - autofs4 hang in 2.6.37-rc1
autofs4 hang in 2.6.37-rc1
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Ian Kent
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-17 19:24 UTC by Maciej Rutecki
Modified: 2010-12-19 11:55 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.37-rc1
Tree: Mainline
Regression: Yes


Attachments
Patch - remove ioctl mutex (1.74 KB, patch)
2010-12-06 03:47 UTC, Ian Kent
Details | Diff

Description Maciej Rutecki 2010-11-17 19:24:20 UTC
Subject    : autofs4 hang in 2.6.37-rc1
Submitter  : Avi Kivity <avi@redhat.com>
Date       : 2010-11-14 12:55
Message-ID : 4CDFDC2B.6040205@redhat.com
References : http://marc.info/?l=linux-kernel&m=128973936026185&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2010-11-30 11:31:41 UTC
According to the referenced thread the resolution is to drop the autofs4_ioctl_mutex, as it is probably not needed.
Comment 2 Ian Kent 2010-11-30 13:03:45 UTC
I thought Arnd Bergmann would post an update to his patch
series to remove that mutex.

If Arnd is too busy I can do the patch, Arnd?
Comment 3 Arnd Bergmann 2010-11-30 16:15:58 UTC
Ah, sorry about that, I thought you'd post the patch ;-)

I'd be happier if you can do the patch yourself, since you can actually test it.
Comment 4 Ian Kent 2010-12-01 09:15:47 UTC
(In reply to comment #3)
> Ah, sorry about that, I thought you'd post the patch ;-)
> 
> I'd be happier if you can do the patch yourself, since you can actually test
> it.

Will do.
Comment 5 Ian Kent 2010-12-06 03:47:16 UTC
Created attachment 39032 [details]
Patch - remove ioctl mutex

Remove the ioctl mutex added during BKL removal.
Comment 6 Ian Kent 2010-12-06 03:53:35 UTC
Patch posted.
Comment 7 Rafael J. Wysocki 2010-12-06 22:11:34 UTC
Patch : https://bugzilla.kernel.org/attachment.cgi?id=39032
Handled-By : Ian Kent <raven@themaw.net>
Comment 8 Ian Kent 2010-12-07 05:05:42 UTC
(In reply to comment #6)
> Patch posted.

and posted again with appropriate anotations.
Comment 9 Rafael J. Wysocki 2010-12-19 11:55:14 UTC
Fixed by commit de47de7 autofs4 - remove ioctl mutex (bz23142) .

Note You need to log in before you can comment on or make changes to this bug.