Bug 2303 - usb mouse randomly stops working
Summary: usb mouse randomly stops working
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Dmitry Torokhov
Depends on:
Reported: 2004-03-14 20:04 UTC by Anand Kumria
Modified: 2008-03-03 18:39 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.2, 2.6.3
Regression: ---
Bisected commit-id:


Description Anand Kumria 2004-03-14 20:04:22 UTC
Distribution: Debian unstable
Hardware Environment: AMD Athlon XP 1800+ w/
Software Environment: 2.6.3 with VMware modules; 2.6.2 untainted kernel.
Problem Description:

After random intervals my USB mouse ceases to work. I notice this as the power
led on the mouse disappears. Unfortunately no kernel messages are logged yet I
can disconnect the device (unplug it) and plug it back in and it receives power.

usb 1-2: USB disconnect, address 6
usb 1-2: new low speed USB device using address 7
input: USB HID v1.10 Mouse [Microsoft Microsoft 3-Button Mouse with
IntelliEye(TM)] on usb-0000:00:11.2-2

are messages logged with dmesg
akumria@clam [~] $ 516 cat /proc/bus/input/handlers 
N: Number=0 Name=kbd
N: Number=1 Name=mousedev Minor=32
akumria@clam [~] $ 517 cat /proc/bus/input/devices 
I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
H: Handlers=kbd 
B: EV=120003 
B: KEY=4 2000000 3802078 f840d001 f2ffffdf ffefffff ffffffff fffffffe 
B: LED=7 

I: Bus=0003 Vendor=045e Product=0040 Version=0300
N: Name="Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)"
P: Phys=usb-0000:00:11.2-2/input0
H: Handlers=mouse0 
B: EV=7 
B: KEY=70000 0 0 0 0 0 0 0 0 
B: REL=103 

Steps to reproduce:

Wait a random amount of time ... curse when mouse led disappears. Unplug USB
device and plug back in.
Comment 1 Hannes Hauswedell 2004-08-12 05:38:34 UTC
i have got the same problem, after random amount of time the mouse pointer just  
wont move any further, in addition the system is a little unstable after that.  
i cannot change terminals (with the ctrl+alt+f*) and it mostly freezes on  
shutdown, logoff, or reboot.my dmesg looks different though so it may be a 
different bug:  
irq 7: nobody cared!  
Call Trace:  
 [<c010b60a>] __report_bad_irq+0x2a/0x90  
 [<c010b6fc>] note_interrupt+0x6c/0xa0  
 [<c010b9d1>] do_IRQ+0x121/0x130  
 [<c0109ce4>] common_interrupt+0x18/0x20  
[<e21a4c10>] (usb_hcd_irq+0x0/0x70 [usbcore])  
[<e21a4c10>] (usb_hcd_irq+0x0/0x70 [usbcore])  
[<e21a4c10>] (usb_hcd_irq+0x0/0x70 [usbcore])  
Disabling IRQ #7  
i am using a pre-compiled (i know, i know...) 2.6.5 kernel for athlon cpus on  
debian sid. only extra loaded modules are nvidia drivers i think.  
Comment 2 Hannes Hauswedell 2004-08-12 06:01:47 UTC
i just wanted to add that i use a logitech mx700 wireless optical mouse.  
and btw i think this bug is pretty important (having to restart that often) so 
i would be happy to see severity increased ;) 
Comment 3 George 2004-09-19 14:34:42 UTC
Distribution: Debian unstable

Hardware Environment: P4 mobile 1600 (hp omnibook xt1500), USB controller: VIA
Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 23)

Software Environment:, affected: 2.6.x

Problem Description:

I noticed this problem with all 2.6 kernels (including I don't
remember if the 2.4 worked (I don't have 2.4 anymore).

1-If the mouse stops while in X, switch to a console and go back to X solves the
2-If the mouse stops while in console, switching into X and back to console
doesn't helps
3-In any case (X or console), restarting hotplug or unplug and plug the mouse
solves the problem
4-With two USB mouses it's more strange: use one mouse normally and have the
other still. When the moving mouse stops working, a little movement or button
click on the other solves the problem
5-With two USB mouses, moving them at the same time, randomly both stop working
6-In any case, the mouse stops working randomly all the time (sometimes every 2
7-The mouse light doesn't stops

I have a synaptics touchpad and it works all the time, even if the mouse stops

When the mouse hangs occurs, the kernel doesn't log anything in dmesg and I have
not noticed any unstability.

I've tried four different USB mouses and all work well with XP and have random
hangs in Linux.

I think RedHat has a bug report for this (
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=128382 ).

(sorry for my english)
Comment 4 George 2004-09-19 14:44:25 UTC
I found this: using one mouse and have another still (both of them USB). When
the moving mouse stops working, i can -for example- move it to a corner (nothing
happens to the screen cursor) but after moving the other mouse (the one that was
still) the cursor goes to that corner.

It's like the kernel is answering the mouse interrupts partially (because
nothing happens to the screen cursor) but the movements are not lose.
Comment 5 Stefano 2004-10-31 14:59:03 UTC
running gentoo with kernels>2.6.5 (til 2.6.9) on a laptop acer aspire 1300xv
with VIA usb controller there  are the same problems 
usb mouse stops, I have to unplug and plug again or press ctrl+alt+f1 then alt+f7.
using 2 usb mice, if one freezes, moving the other one will unfreeze the first...
 running gnomemeeting with usb webcam enabled prevent mouse to freeze
Comment 6 Stefano 2004-11-15 09:29:23 UTC
I've compiled ACPI modules (fan,processor, ac, battery...)and autoloaded 
I don't know why but now mouse seems to work 
acpid is not started.... 
Comment 7 Anand Kumria 2005-01-12 21:33:50 UTC

So, with 2.6.10 (with and without VMware modules loaded) I get the following logged:

Jan 13 15:03:04 clam kernel: drivers/usb/input/hid-core.c: input irq status -84
Jan 13 15:05:01 clam kernel: drivers/usb/input/hid-core.c: input irq status -84
Jan 13 15:05:29 clam kernel: usb 2-2: USB disconnect, address 6
Jan 13 15:05:29 clam udev[5130]: removing device node '/dev/input/mouse0'
Jan 13 15:05:29 clam hal.hotplug[5139]: DEVPATH is not set
Jan 13 15:05:30 clam kernel: usb 2-2: new low speed USB device using uhci_hcd
and address 7
Jan 13 15:05:31 clam kernel: input: USB HID v1.10 Mouse [Microsoft Microsoft
3-Button Mouse with IntelliEye(TM)] on usb-0000:00:04.3-2
Jan 13 15:05:31 clam udev[5191]: configured rule in
'/etc/udev/rules.d/udev.rules' at line 55 applied, 'mouse0' becomes 'input/%k'
Jan 13 15:05:31 clam udev[5191]: creating device node '/dev/input/mouse0'
Jan 13 15:05:31 clam hal.hotplug[5215]: DEVPATH is not set
Jan 13 15:05:32 clam usb.agent[5197]:      usbhid: already loaded
Comment 8 Hannes Hauswedell 2005-12-24 19:00:58 UTC
i just realised on my machine and most posts here the people have via 
chipsets... maybe its connected... 
nowadays i use freebsd and have similar problems, i.e. the freebsd kernel 
reports problems when trying to use the usb ports and deactivates them(i cant 
use them at all). so i figured maybe my usb controller on the mobo is just 
p.s.: the problems are not connected to mice, but occur on all usb devices 
Comment 9 Natalie Protasevich 2007-09-04 19:04:55 UTC
Anu updates on this bug please.
Comment 10 Natalie Protasevich 2008-03-03 18:39:01 UTC
OK, this bug is sufficiently old to assume the problem is gone.
Closing, please reopen if it shows up again.

Note You need to log in before you can comment on or make changes to this bug.