Bug 22912 - spi_lm70llp module crash on unload (2.6.37-rc1)
spi_lm70llp module crash on unload (2.6.37-rc1)
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-14 19:58 UTC by Maciej Rutecki
Modified: 2011-02-12 23:03 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.7.37-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-11-14 19:58:52 UTC
Subject    : spi_lm70llp module crash on unload (2.6.37-rc1)
Submitter  : Randy Dunlap <randy.dunlap@oracle.com>
Date       : 2010-11-05 0:16
Message-ID : 20101104171620.00d8c95d.randy.dunlap@oracle.com
References : http://marc.info/?l=linux-kernel&m=128891627913647&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Randy Dunlap 2010-11-19 21:29:23 UTC
Still happens with 2.6.37-rc2-git4.
Comment 2 Randy Dunlap 2010-12-07 18:19:09 UTC
Still happens with 2.6.37-rc5.
Comment 3 Randy Dunlap 2010-12-28 17:20:24 UTC
Still happens on 2.6.37-rc7.
Comment 4 Randy Dunlap 2011-02-07 04:03:19 UTC
I cannot reproduce this problem on 2.6.38-rc3.  Nothing has
changed in the driver source code AFAICT: drivers/spi/spi_lm70llp.c
has not been updated since June 30, 2010.

Please close this bug report.
Comment 5 Florian Mickler 2011-02-09 05:30:46 UTC
This looks like some race condition (the dmesg is all messed up...)
Probably somewhere a missing locking. Maybe some fallout of bkl removal?

I'm closing it as unreproducible for now.

Note You need to log in before you can comment on or make changes to this bug.