Bug 22902 - hwmon/adt7470 crash on module load (2.6.37-rc1)
hwmon/adt7470 crash on module load (2.6.37-rc1)
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: I2C
All Linux
: P1 normal
Assigned To: Jean Delvare
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-14 19:50 UTC by Maciej Rutecki
Modified: 2010-11-18 23:12 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.37-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-11-14 19:50:05 UTC
Subject    : hwmon/adt7470 crash on module load (2.6.37-rc1)
Submitter  : Randy Dunlap <randy.dunlap@oracle.com>
Date       : 2010-11-05 0:09
Message-ID : 20101104170929.f5198be3.randy.dunlap@oracle.com
References : http://marc.info/?l=linux-kernel&m=128891583513099&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Jean Delvare 2010-11-14 20:14:13 UTC
This has already been investigated and there is no hint that the adt7470 driver actually has anything to do with the crash. Additionally, Randy reported that he is unable to reproduce the crash.

I have sent a candidate patch for testing (fixing a couple obvious bugs in the i915 driver) and am waiting for Randy to report. That being said, the non-reproducibility of the bug means we won't be able to draw any conclusion from that report.
Comment 2 Randy Dunlap 2010-11-15 00:52:43 UTC
Darn, I thought that I had replied to that patch.
Sorry about that.

For your patch to drivers/gpu/drm/i915/intel_i2c.c:
Tested-by: Randy Dunlap <randy.dunlap@oracle.com>

Thanks.

Yes, this particular bug report can be closed as invalid.

Note You need to log in before you can comment on or make changes to this bug.