Bug 2278 - ipod disconnects after a while and reconnects not as sdb but sdc...
ipod disconnects after a while and reconnects not as sdb but sdc...
Status: REJECTED WILL_NOT_FIX
Product: Drivers
Classification: Unclassified
Component: IEEE1394
i386 Linux
: P2 normal
Assigned To: Stefan Richter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-09 14:14 UTC by elias
Modified: 2005-10-01 01:41 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.3
Tree: Mainline
Regression: ---


Attachments
dmesg output log (14.98 KB, text/plain)
2004-03-09 14:17 UTC, elias
Details

Description elias 2004-03-09 14:14:28 UTC
Distribution: Debian testing	  
Hardware Environment: Vaio PCG-C1MHP + iPod 30 gig (2003)  
Software Environment: gtkpod  
Problem Description:  
I had the same problem as described under bug #1872 with 2.6.1.  
  
Now I can connect to iPod with 2.6.3 now, but the connection brakes after a  
short time and the ipod is reconnected at sdc while it was on sdb before and so  
on, what leafs my gtkpod app waiting forever, since I can't manage to umount  
the lost sdb2 connection to remount sdc2 to /mnt/ipod.  
  
I have compiled ieee1394, ohci1394, sbp2 and sd_mod directly into kernel. If  
you need the kernel config or something else, just ask.  
By the way all this was working in 2.4.20+ but getting the device connected was  
far more work, so thanks for that part of your work!  
  
I have added my dmesg log.  
  
Steps to reproduce:  
Take iPod, mount somewhere transfer big amount of data (I think I have to write  
to iPod, since I could download several gigs without problems) or wait a while  
and voila, there it is.
Comment 1 elias 2004-03-09 14:17:06 UTC
Created attachment 2306 [details]
dmesg output log

dmesg.log
Comment 2 Nishanth Aravamudan 2005-06-17 14:18:32 UTC
Does this still occur with 2.6.11.12 or 2.6.12-rc6?

Thanks,
Nish
Comment 3 Stefan Richter 2005-07-24 02:23:04 UTC
The repeated bus resets that are shown in your dmesg log indicate that there is
a harwdare problem: Bad cable, noisy controller, noisy front panel or back panel
connector...

Linux 2.4 simply handles such conditions a bit more graceful than the 2.6
version you have installed. You could try 2.6.12 which may a bit more successful
with such problems as well, although there are still regressions from 2.4 to 2.6.12.
Comment 4 Stefan Richter 2005-07-24 02:48:09 UTC
I looked up information about Vaio PCG-C1MHP Picturebook. I assume you use the
onboard connector of the Picturebook, i.e. there are no such things as front or
back panel connectors which could introduce noise. A bad cable, EMI or heat
problems in the Picturebook or even in the iPod remain as possible causes for
the repeated bus resets.

The problem that scsi disk device files are enumerated through sda, sdb, etc.
were fixed at some point in Linux 2.6. I don't remember the particular
subrelease. However, these problems may be introduced again at any new Linux 2.6
release since we still struggle to get hotplugging right between sbp2 and the
scsi subsystem.

However, I changed this bug to "rejected/ will_not_fix" because we cannot fix
the underlying hardware problem. We can only try to make the drivers as robust
as possible in situations of bus resets. (And I hope we will get Linux 2.6 at
least as robust as 2.4 eventually.) But ultimately we cannot provide a software
solution to an evident hardware fault.
Comment 5 Stefan Richter 2005-10-01 01:41:41 UTC
The hot(un)plug trouble between sbp2 and SCSI subsystem that I referred to in
the previous comment has been fixed in 2.6.14-rc3.

Note You need to log in before you can comment on or make changes to this bug.