Bug 22712 - PROBLEM: i915 modesetting - weird offset graphics (v2.6.37-rc1-27-gff8b16d)
PROBLEM: i915 modesetting - weird offset graphics (v2.6.37-rc1-27-gff8b16d)
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-11 08:01 UTC by Maciej Rutecki
Modified: 2010-11-18 23:03 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.37-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-11-11 08:01:51 UTC
Subject    : PROBLEM: i915 modesetting - weird offset graphics (v2.6.37-rc1-27-gff8b16d)
Submitter  : Jon Masters <jonathan@jonmasters.org>
Date       : 2010-11-04 7:25
Message-ID : 1288855558.3916.293.camel@constitution.bos.jonmasters.org
References : http://marc.info/?l=linux-kernel&m=128885554402886&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Jon Masters 2010-11-11 08:38:23 UTC
I identified the problem over the weekend using a bisection and Chris and I worked out a patch. I am waiting for this to show up:

http://lists.freedesktop.org/archives/intel-gfx/2010-November/008728.html

Jon.
Comment 2 Chris Wilson 2010-11-11 09:13:30 UTC
The patch has been included in a pull request to Linus via airlied/drm-fixes.
Comment 3 Jon Masters 2010-11-11 09:26:20 UTC
Thanks Chris.
Comment 4 Rafael J. Wysocki 2010-11-18 23:03:32 UTC
Fixed by  commit 3f8ff0e72d75fdbe7f2cba2c4015fd9fdd9e13fd .

Note You need to log in before you can comment on or make changes to this bug.