Bug 22692 - [regression, 2.6.37-rc1] 'ip link tap0 up' stuck in do_exit()
Summary: [regression, 2.6.37-rc1] 'ip link tap0 up' stuck in do_exit()
Status: CLOSED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 14885
  Show dependency tree
 
Reported: 2010-11-11 07:45 UTC by Maciej Rutecki
Modified: 2012-06-14 17:35 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.37-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-11-11 07:45:32 UTC
Subject    : [regression, 2.6.37-rc1] 'ip link tap0 up' stuck in do_exit()
Submitter  : Dave Chinner <david@fromorbit.com>
Date       : 2010-11-03 6:26
Message-ID : 20101103062609.GB31163@dastard
References : http://marc.info/?l=linux-kernel&m=128876560131870&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2010-11-30 11:48:57 UTC
I changed it to the 2.6.35 regression list.
> Actually, the machine isn't running a 2.6.36 kernel (it had booted
> to the working .35 kernel and I didn't notice). So i've just tested
> a 2.6.36 kernel, and the problem _is present_ in 2.6.36. 
> Cheers,
> Dave.
Comment 2 Florian Mickler 2010-11-30 11:52:36 UTC
Also present in 2.6.32 (Should have finished reading that thread). 
Note that earlier kernels were not tested, so it's not clear that it is a regression at all... 

Did this got resolved in the meantime?
Comment 3 Dave Chinner 2010-11-30 21:56:42 UTC
(In reply to comment #2)
> Also present in 2.6.32 (Should have finished reading that thread). 
> Note that earlier kernels were not tested, so it's not clear that it is a
> regression at all... 
> 
> Did this got resolved in the meantime?

No, not resolved. I diagnosed it to being related to a distro sudo configuration change causing the problem:

http://marc.info/?l=linux-netdev&m=128883013013886&w=2

and as far as I'm aware nothing has happened from there.

Note You need to log in before you can comment on or make changes to this bug.