Bug 22572 - Linux 2.6.37-rc1 (acpi_video)
Linux 2.6.37-rc1 (acpi_video)
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: acpi_power-video
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-09 20:45 UTC by Maciej Rutecki
Modified: 2010-12-06 21:57 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.37-rc1
Tree: Mainline
Regression: Yes


Attachments
patch: poulsbo sub driver selects INPUT (628 bytes, patch)
2010-11-10 02:33 UTC, Zhang Rui
Details | Diff

Description Maciej Rutecki 2010-11-09 20:45:19 UTC
Subject    : Linux 2.6.37-rc1 (acpi_video)
Submitter  : Randy Dunlap <randy.dunlap@oracle.com>
Date       : 2010-11-02 18:51
Message-ID : 20101102115106.bac57d21.randy.dunlap@oracle.com
References : http://marc.info/?l=linux-kernel&m=128872403920449&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Zhang Rui 2010-11-10 02:33:29 UTC
Created attachment 36992 [details]
patch: poulsbo sub driver selects INPUT

Yes, we can fix it by the one-line patch attached.

But IMO, the real problem is that poulsbo stub driver should not select ACPI video driver at all, because there is no dependency between these two drivers.
References: http://marc.info/?l=linux-acpi&m=128874714517914&w=2
Comment 2 Randy Dunlap 2010-11-19 00:04:37 UTC
Yes, the build is fixed by the patch attachment above.

Unfortunately, I was trying to build a kernel with CONFIG_INPUT disabled,
and this STUB driver now makes that impossible, but I suppose that's a different problem.

This one can be closed.
Comment 3 Rafael J. Wysocki 2010-11-19 00:06:59 UTC
Patch : https://bugzilla.kernel.org/attachment.cgi?id=36992
Handled-By : Zhang Rui <rui.zhang@intel.com>

Note You need to log in before you can comment on or make changes to this bug.