Bug 2250 - S3 resume: no video - Dell Latitude x200
S3 resume: no video - Dell Latitude x200
Status: REJECTED DUPLICATE of bug 7225
Product: Drivers
Classification: Unclassified
Component: Video(Other)
i386 Linux
: P2 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-04 15:45 UTC by Craig Maloney
Modified: 2007-04-28 12:49 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.3
Tree: Mainline
Regression: ---


Attachments
various dump files: dmesg, acpidmp, dmidecode, etc. (51.70 KB, application/gzip)
2004-03-04 15:47 UTC, Craig Maloney
Details

Description Craig Maloney 2004-03-04 15:45:02 UTC
Distribution: debian testing
Hardware Environment: dell latitude x200 bios A09
Software Environment: 

Problem Description:
My dell x200 laptop will not wakeup from an S3 sleep state.  After issuing an
echo -n "mem" > /sys/power/state, the system proceeds to suspend much as it does
in win2k.  The power light goes off and the battery light starts to blink
instead of being steadily illuminated (system is plugged into ac throughout the
procedure).  When I subsequently hit the power button, the battery light stops
flashing and goes black and the system must be hard reset (unplug battery,
unplug power, wait for some time, replug power, hit power button) to do
anything.  This is similar behavior to bug #1415 -- but the fixes described
there do not work.

Steps to reproduce:
Starting from pristine 2.6.3 sources, apply acpi-2.6.3-20040220 patch and:
http://bugzilla.kernel.org/attachment.cgi?id=1692&action=view

After boot cat /proc/acpi/wakeup_devices.
All wakeup_devices are initially disabled.
Enable PWRB:  cat "PWRB" > /proc/acpi/wakeup_devices
Verify that PWRB is enabled as a wakeup device.

Comments:
There is a dsdt fix (c.f. http://acpi.sourceforge.net/dsdt/view.php?id=60
http://modperl.com:9000/x200/dsdt_details.html) which allows to see the battery.
 Presumably this should be unrelated and the behavior seems to be independent of
using the dell dsdt or the fixed dsdt.  Also seems to be independent of bios
versions A05 vs A09.

Incidental: neither of the two other supported sleep states "suspend" "disk" do
anything.

Behavior is generic with respect to:
bios version
dsdt (dellA05, dellA09, or battery fix)
pci=noacpi
Comment 1 Craig Maloney 2004-03-04 15:47:22 UTC
Created attachment 2285 [details]
various dump files: dmesg, acpidmp, dmidecode, etc.
Comment 2 Venkatesh Pallipadi 2004-10-29 15:49:51 UTC
Is the problem still there with 2.6.9?
Comment 3 Craig Maloney 2004-10-29 16:23:57 UTC
Yep... as a matter of fact, I tried 2.6.9 last week.  I did not, however, apply
the latest ACPI patch, nor did I apply the wakeup_devices patch as I did with
2.6.3.  Same behavior:  LED stops flashing after I try to wake up, and the thing
remains comatose.  Thanks.  
Comment 4 Venkatesh Pallipadi 2004-11-03 18:53:28 UTC
Is the problem still there with latest 2.6 kernel?

If yes, can you make sure whether the problem is only with restore of the 
video (try connecting through network or serial after resume).

If it is only the video problem, 
- Please try the options in Documentation/power/video.txt
- Try the workaround in bug #3670
Comment 5 Craig Maloney 2004-11-05 23:46:57 UTC
Oops... my bad.  It was 2.6.8 that I had just tried.  So just now, I tried
2.6.9.  Sure enough there was a /proc/acpi/wakeup waiting there for me, and if I
cat'ed it, I see PWRB with a 5 and a star!  Presumably that's good :).  Now
after being suspended, the LED and fan come back on when I hit the power button
*yeah!*  Unfortunately, video_post doesn't bring the console back *boo!*.  But
now, it's at least got a pulse, so I can tweak it.  Shucks... I can even hold
down the power button for 5 seconds, and I don't need to take out the battery.  
I'll rebuild a more reasonable kernel with networking, so I can get in there and
tweak.

More to follow... (hopefully).
Comment 6 Len Brown 2005-01-03 14:27:27 UTC
Please re-open if still a problem with linux-2.6.10 or later.
Comment 7 Marten van Kerkwijk 2006-07-03 09:28:18 UTC
I would like to re-open this bug.  I have a Dell X200 as well, and encounter the
same problem as described below (with kernel version 2.6.17)

When I suspend to ram, it seems to work, but on resume the machine hangs

- screen blank and black
- no keyboard -- caps lock doesn't do anything and typing things like
  "ls", "find /" doesn't do anything; 
- no network -- cannot ssh in

I tried using "echo mem >/sys/power/state", or s2ram (from muswsusp 0.2) with
any of its options. I also tried booting with "init=/bin/bash", "vga=0" (default
anyway for me), "nolapic", "noapic",...

Any tips to try to debug this more systematically would be appreciated.

Thanks,

Marten


Comment 8 Len Brown 2006-08-09 20:19:58 UTC
ACPI is not responsible for restoring video on S3 resume,
it is the job of the BIOS or video driver.  Moving this bug
to Drivers/Video.
Comment 9 Rafael J. Wysocki 2006-09-28 09:40:10 UTC
Craig, please see http://en.opensuse.org/S2ram, the inctructions in there may
help fix the problem.  If they do, please close this bug.
Comment 10 Rafael J. Wysocki 2006-09-28 10:25:49 UTC

*** This bug has been marked as a duplicate of 7225 ***

Note You need to log in before you can comment on or make changes to this bug.