Bug 22472 - vga_switcheroo fails to switch from intel to ati
vga_switcheroo fails to switch from intel to ati
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 high
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-08 16:46 UTC by Radu Andries
Modified: 2011-01-29 10:45 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.37-rc1-00116-g151f52f-dirty
Tree: Mainline
Regression: Yes


Attachments
Me blindly switching cards (40.48 KB, text/plain)
2010-11-08 16:46 UTC, Radu Andries
Details

Description Radu Andries 2010-11-08 16:46:43 UTC
Created attachment 36752 [details]
Me blindly switching cards

device is a Acer 4820TG

lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 12)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
01:00.0 VGA compatible controller: ATI Technologies Inc Device 68e0
01:00.1 Audio device: ATI Technologies Inc Device aa68
02:00.0 Ethernet controller: Atheros Communications AR8151 v1.0 Gigabit Ethernet (rev c0)
03:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
7f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
7f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
7f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
7f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
7f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
7f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

dmesg attached

PS  switched to ati and screen froze, blindly switching back to intel works
Comment 1 Radu Andries 2010-11-10 20:15:05 UTC
This is a *regression* compared to 2.6.35
Comment 2 Rafael J. Wysocki 2010-11-10 20:40:38 UTC
OK, it's being tracked now.
Comment 3 Radu Andries 2010-11-10 21:13:36 UTC
Haven't tried 2.6.36 yet...
Comment 4 Radu Andries 2010-11-11 04:22:19 UTC
bug not present in 2.6.36
Comment 5 Florian Mickler 2010-11-12 08:02:59 UTC
ok, i reclassified it as a regression from 2.6.36. 

Your version strings reads: "2.6.37-rc1-00116-g151f52f-dirty" (note the -dirty).  I assume you have no relevant (to the issue at hand) changes in your working copy?
Comment 6 Radu Andries 2010-11-12 08:45:51 UTC
No patches applied if that's what you mean.
Comment 7 Florian Mickler 2010-11-16 19:40:47 UTC
hmm.. I wonder why there is "-dirty" appended to the version... that normally means, that there were uncommitted changes in the working directory when you compiled the tree...

"git diff" should show you... If you didn't intentionally change anything, you can just do "git reset --hard" which will reset all files to it's original state... but this looses all changes... obviously..

Regards,
Flo
Comment 8 Radu Andries 2010-11-17 08:07:55 UTC
You are right. I change logo to archlinux's so git gets mad.

Here is the build i do. http://tracker.kromonos.net/repositories/browse/nightlyarch/kernel26-git

NO patches applied.
Comment 9 Radu Andries 2010-11-17 08:08:25 UTC
You are right. I change logo to archlinux's so git gets mad.

Here is the build i do. http://tracker.kromonos.net/repositories/browse/nightlyarch/kernel26-git
Comment 10 Radu Andries 2010-11-19 21:31:46 UTC
Should i compile rc2 again without anything? Any other info needed?
Comment 11 Florian Mickler 2010-11-30 12:11:19 UTC
You could try the latest kernel. 

I can't see any error in your dmesg. From the description I assume that the radeon card is at fail. 

If nobody pipes up with any other sugestion,  a bisection to find the offending commit should get us somewhere. (see `man git-bisect`)
Comment 12 Radu Andries 2010-11-30 21:40:03 UTC
Setting ati in BIOS + boot with latest kernel26-git is successful. it's the switch...

I'll try asap and post results. oh mighty ccache help me!
Comment 13 Florian Mickler 2010-12-17 01:17:14 UTC
Did you find anything useful?
Comment 14 Radu Andries 2010-12-17 09:33:35 UTC
It's 12 steps between 2.6.36 and 2.6.37-rc1... I have still to compile && try :(
Comment 15 Radu Andries 2011-01-29 00:54:54 UTC
Someone fixed it somehow. In final 2.6.37 all works fine
Comment 16 Florian Mickler 2011-01-29 10:45:21 UTC
Good to hear! Because we don't know the commit that fixed it, I change the resolution field to 'unreproducible'.

Note You need to log in before you can comment on or make changes to this bug.