Bug 22312 - [drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
Summary: [drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-07 09:21 UTC by Cesko Voeten
Modified: 2014-09-29 14:32 UTC (History)
7 users (show)

See Also:
Kernel Version: 3.1
Tree: Mainline
Regression: No


Attachments
uname -a, lspci, dmesg (61.51 KB, text/plain)
2010-11-07 09:21 UTC, Cesko Voeten
Details
dmesg (95.61 KB, application/octet-stream)
2011-08-31 07:46 UTC, Idar Lund
Details
uname -a, lspci -v -s 01:00.0, dmesg (77.18 KB, text/plain)
2013-12-11 16:07 UTC, Dmitry
Details
attachment-26341-0.html (1.44 KB, text/html)
2013-12-12 14:32 UTC, xpressrazor
Details

Description Cesko Voeten 2010-11-07 09:21:45 UTC
Created attachment 36402 [details]
uname -a, lspci, dmesg

Hi :-)

I'm trying to get vga_switcheroo to work to switch between integrated Intel and ATI Radeon graphics. Intel is set to primary display ('init display first') in BIOS. The radeon driver appears to not like this:


[    3.464108] [drm] radeon defaulting to kernel modesetting.
[    3.464110] [drm] radeon kernel modesetting enabled.
[    3.464152] radeon 0000:01:00.0: enabling device (0000 -> 0003)
[    3.464159] radeon 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    3.464164] radeon 0000:01:00.0: setting latency timer to 64
[    3.479214] i915 0000:00:02.0: irq 46 for MSI/MSI-X
[    3.484895] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=none:owns=io+mem
[    3.484898] vgaarb: transferring owner from PCI:0000:00:02.0 to PCI:0000:01:00.0
[    4.029065] Console: switching to colour frame buffer device 160x45
[    4.030765] fb0: inteldrmfb frame buffer device
[    4.030766] drm: registered panic notifier
[    4.030800] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[    4.032334] [drm] initializing kernel modesetting (CEDAR 0x1002:0x68F9).
[    4.032664] [drm] register mmio base: 0xFBDC0000
[    4.032666] [drm] register mmio size: 131072
[    4.032750] radeon 0000:01:00.0: Invalid ROM contents
[    4.032821] radeon 0000:01:00.0: Invalid ROM contents
[    4.032860] [drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
[    4.032896] radeon 0000:01:00.0: Fatal error during GPU init
[    4.032929] [drm] radeon: finishing device.
[    4.032931] [TTM] Memory type 2 has not been initialized.
[    4.034076] vga_switcheroo: disabled
[    4.034160] radeon 0000:01:00.0: PCI INT A disabled
[    4.034168] radeon: probe of 0000:01:00.0 failed with error -22

When I disable the Intel card it works fine. The radeon card is a HD 5450, by the way.

I have attached dmesg, uname -a, and lspci.

(This is my first bug report on kernel.org so please be gentle ;-))

Thanks for anything you can do :-)
Comment 1 xpressrazor 2011-08-09 12:20:44 UTC
[   15.931030] Linux video capture interface: v2.00
[   15.948984] [drm] radeon defaulting to kernel modesetting.
[   15.948987] [drm] radeon kernel modesetting enabled.
[   15.949030] radeon 0000:01:00.0: enabling device (0000 -> 0003)
[   15.949040] radeon 0000:01:00.0: found PCI INT A -> IRQ 11
[   15.949046] radeon 0000:01:00.0: sharing IRQ 11 with 0000:00:02.0
[   15.949051] radeon 0000:01:00.0: sharing IRQ 11 with 0000:00:16.0
[   15.949055] radeon 0000:01:00.0: sharing IRQ 11 with 0000:00:1a.0
[   15.949114] radeon 0000:01:00.0: sharing IRQ 11 with 0000:02:00.0
[   15.949126] radeon 0000:01:00.0: setting latency timer to 64
[   15.949409] [drm] initializing kernel modesetting (CAICOS 0x1002:0x6760).
[   15.949466] [drm] register mmio base: 0xE1700000
[   15.949468] [drm] register mmio size: 131072
[   15.949997] radeon 0000:01:00.0: Invalid ROM contents
[   15.950088] radeon 0000:01:00.0: Invalid ROM contents
[   15.950116] [drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
[   15.950120] radeon 0000:01:00.0: Fatal error during GPU init
[   15.950124] [drm] radeon: finishing device.
[   15.950126] [TTM] Memory type 2 has not been initialized.
[   15.951164] vga_switcheroo: disabled
[   15.951383] radeon: probe of 0000:01:00.0 failed with error -22

I have similar problem. This problem comes in all kernels(2.6.38-8, 2.6.38-10, 3.0.0-0300 and 3.0.1). I have Intel sandy bridge i5 processor.  

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M]

$ lspci -v -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Dell Device 04c1
	Flags: bus master, fast devsel, latency 0, IRQ 25
	Memory at e0000000 (64-bit, non-prefetchable) [size=4M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 5000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915

$ lspci -v -s 01:00.0
01:00.0 VGA compatible controller: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M] (prog-if 00 [VGA controller])
	Subsystem: Dell Device 04c1
	Flags: fast devsel, IRQ 11
	Memory at c0000000 (64-bit, prefetchable) [disabled] [size=256M]
	Memory at e1700000 (64-bit, non-prefetchable) [disabled] [size=128K]
	I/O ports at 4000 [disabled] [size=256]
	Expansion ROM at e1720000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel modules: radeon

$ uname -r
2.6.38-8-generic

Above 3.0 kernel intel's card seems to work a lot better, but radeon error comes anyway.
Comment 2 Idar Lund 2011-08-31 07:46:07 UTC
Created attachment 70942 [details]
dmesg

I've got the same problems. Though my radeon VGA is in an external port replicator.

[    1.347670] [drm] radeon defaulting to kernel modesetting.
[    1.347671] [drm] radeon kernel modesetting enabled.
[    1.347747] radeon 0000:16:00.0: enabling device (0000 -> 0003)
[    1.347758] radeon 0000:16:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[    1.347772] radeon 0000:16:00.0: setting latency timer to 64
[    1.348026] radeon 0000:16:00.0: Invalid ROM contents
[    1.348137] radeon 0000:16:00.0: Invalid ROM contents
[    1.348192] [drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
[    1.348237] radeon 0000:16:00.0: Fatal error during GPU init
[    1.348280] [drm] radeon: finishing device.
[    1.349479] radeon 0000:16:00.0: PCI INT A disabled
[    1.349483] radeon: probe of 0000:16:00.0 failed with error -22

$ lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device 0126 (rev 09)
16:00.0 VGA compatible controller: ATI Technologies Inc Device 6740


$ lspci -v -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation Device 0126 (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Sony Corporation Device 9084
	Flags: bus master, fast devsel, latency 0, IRQ 53
	Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
	Memory at a0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at a000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: i915

$ lspci -v -s 16:00.0
16:00.0 VGA compatible controller: ATI Technologies Inc Device 6740 (prog-if 00 [VGA controller])
	Subsystem: Sony Corporation Device 9084
	Physical Slot: 1-2
	Flags: fast devsel, IRQ 17
	Memory at b0000000 (64-bit, prefetchable) [size=256M]
	Memory at c0200000 (64-bit, non-prefetchable) [size=128K]
	I/O ports at 5000 [size=256]
	Expansion ROM at c0240000 [disabled] [size=128K]
	Capabilities: <access denied>

$ uname -a
Linux efflap 3.1.0-rc4 #1 SMP Mon Aug 29 12:18:01 CEST 2011 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Alex Deucher 2013-12-10 22:51:26 UTC
Is this still an issue with a newer version of the driver?
Comment 4 Cesko Voeten 2013-12-11 11:23:38 UTC
Hi Alex,

I am no longer experiencing the problem, but since this bug still gets new people CC'd to it from time to time I presume that the problem still occurs for some configurations (though not mine). If this is indeed the case then perhaps one of those people should speak up now; I myself no longer experience the issue so I'm afraid I can't be of much use any more.
Comment 5 Dmitry 2013-12-11 16:07:09 UTC
Created attachment 118051 [details]
uname -a, lspci -v -s 01:00.0, dmesg

Yes, I still have this issue. It doesn't manifest itself. Everything works fine except glamor is sometimes slow. But this doesn't concern the bug.
Comment 6 Alex Deucher 2013-12-11 16:13:47 UTC
(In reply to Dnitry from comment #5)
> Created attachment 118051 [details]
> uname -a, lspci -v -s 01:00.0, dmesg
> 
> Yes, I still have this issue. It doesn't manifest itself. Everything works
> fine except glamor is sometimes slow. But this doesn't concern the bug.

You can ignore that warning in your case because the driver is able to find the vbios eventually.  The driver tried multiple methods to detect the rom depending on the system.
Comment 7 xpressrazor 2013-12-12 14:32:23 UTC
Created attachment 118161 [details]
attachment-26341-0.html

I also don't have this problem anymore. These days, both open source radeon
drivers and closed source catalyst drivers work fine.


On Wed, Dec 11, 2013 at 9:58 PM, <bugzilla-daemon@bugzilla.kernel.org>wrote:

> https://bugzilla.kernel.org/show_bug.cgi?id=22312
>
> --- Comment #6 from Alex Deucher <alexdeucher@gmail.com> ---
> (In reply to Dnitry from comment #5)
> > Created attachment 118051 [details]
> > uname -a, lspci -v -s 01:00.0, dmesg
> >
> > Yes, I still have this issue. It doesn't manifest itself. Everything
> works
> > fine except glamor is sometimes slow. But this doesn't concern the bug.
>
> You can ignore that warning in your case because the driver is able to
> find the
> vbios eventually.  The driver tried multiple methods to detect the rom
> depending on the system.
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>
Comment 8 Chris Nystrom 2014-03-25 23:18:51 UTC
(In reply to Alex Deucher from comment #3)
> Is this still an issue with a newer version of the driver?

Yes. I am having this exact error message with a live Fedora 20 DVD on a Dell OptiPlex 780 with a PCIe ASUS Radeon R7 240 video card. The desktop never comes up.

I am unable to provide further information as I have been unable to install linux due to this issue.

There does not seem to be a way to disable the onboard video in the BIOS on the OptiPlex 780. The only options are "Auto" and "Onboard/Card". There error happens no matter which option is selected.
Comment 9 Alex Deucher 2014-03-26 02:55:29 UTC
(In reply to Chris Nystrom from comment #8)
> Yes. I am having this exact error message with a live Fedora 20 DVD on a
> Dell OptiPlex 780 with a PCIe ASUS Radeon R7 240 video card. The desktop
> never comes up.

Please attach your dmesg output.
Comment 10 Alex Deucher 2014-03-26 02:56:07 UTC
If you are running a 3.13 or newer kernel, try appending radeon.runpm=0 to the kernel command line in grub.
Comment 11 Jarkko K 2014-09-27 08:34:33 UTC
I also have the error and and suddenly these lines

[ 4985.275572] radeon 0000:01:00.0: GPU fault detected: 146 0x0f0a8804
[ 4985.275573] radeon 0000:01:00.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00009678
[ 4985.275574] radeon 0000:01:00.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x0A088004
[ 4985.275576] VM fault (0x04, vmid 5) at page 38520, read from 'TC4' (0x54433400) (136)


r9 290

3.16.6rc kernel
Comment 12 Michel Dänzer 2014-09-29 07:12:11 UTC
(In reply to Jarkko K from comment #11)
> I also have the error and and suddenly these lines
> 
> [ 4985.275572] radeon 0000:01:00.0: GPU fault detected: 146 0x0f0a8804

That's very unlikely to be directly related to the message in the title of this report. Please file a bug at https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa , component Drivers/Gallium/radeonsi .


P.S. Cesko, if you could change the title of this report to something like '[drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM', that might help prevent others from incorrectly considering this report related to their problem.
Comment 13 Cesko Voeten 2014-09-29 07:38:45 UTC
(In reply to Michel Dänzer from comment #12)
> P.S. Cesko, if you could change the title of this report to something like
> '[drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM', that might help
> prevent others from incorrectly considering this report related to their
> problem.

Done! And perhaps it should also be pointed out that my specific problem was that the driver indeed could not locate the BIOS ROM *while my Intel iGPU was set as primary in the BIOS*. Perhaps that might have been a relevant factor.
Comment 14 Alex Deucher 2014-09-29 14:28:06 UTC
Note that this message is still present even when the driver is able to find the vbios rom due to changes in the pci subsystem for the order of methods it uses for fetching the rom.  If the kernel driver loads successfully, these messages can be ignored.
Comment 15 Jarkko K 2014-09-29 14:29:11 UTC
Did you notice what I said?

"I also have the error and and suddenly these lines"

I also had the not able to find bios rom error. line and also those other lines which i pasted.
Comment 16 Alex Deucher 2014-09-29 14:32:33 UTC
(In reply to Jarkko K from comment #15)
> Did you notice what I said?
> 
> "I also have the error and and suddenly these lines"
> 
> I also had the not able to find bios rom error. line and also those other
> lines which i pasted.

The unable to find bios errors can be ignored on your system  they print on just about every system.  They are only a problem when the driver is not able to load.  The driver is able to eventually find the rom and load successfully on your system.  The VM faults are a different issue.

Note You need to log in before you can comment on or make changes to this bug.