Bug 22112 - A couple of Kconfig warnings
A couple of Kconfig warnings
Status: CLOSED WILL_NOT_FIX
Product: Other
Classification: Unclassified
Component: Configuration
All Linux
: P1 normal
Assigned To: other_configuration@kernel-bugs.osdl.org
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-04 19:13 UTC by Maciej Rutecki
Modified: 2010-11-18 23:08 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-11-04 19:13:29 UTC
Subject    : A couple of Kconfig warnings
Submitter  : Fabio Comolli <fabio.comolli@gmail.com>
Date       : 2010-10-30 11:48
Message-ID : AANLkTik41vfVn6K0UDYfoCK7O8j2UHsqhGNdbVckt-PA@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=128843932821411&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Arnaud Lacombe 2010-11-07 20:27:17 UTC
This is not a regression. For years, Documentation/kbuild/kconfig-language.txt had the following comment about the usage of the "select" directive:

  Note: 
        select should be used with care. select will force
        a symbol to a value without visiting the dependencies.
        By abusing select you are able to select a symbol FOO even
        if FOO depends on BAR that is not set.
        In general use select only for non-visible symbols
        (no prompts anywhere) and for symbols with no dependencies.
        That will limit the usefulness but on the other hand avoid
        the illegal configurations all over.
        kconfig should one day warn about such things.

Until 2.6.36, kconfig was not warning (well, it was, but was silenced due to a late bugfix) about these abusive usage. Now it is.

Note You need to log in before you can comment on or make changes to this bug.